Ability to disable Javascript "on Exit"

NEW
Unassigned

Status

--
enhancement
16 years ago
10 years ago

People

(Reporter: c, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016

It happens that advertising banners have themselves as "on exit", so that there 
is no way to exit the page but killing mozilla. 
Suggested solution 1: One should be able to never allow mozilla to open a 
window "on exit". 
Suggested solution 2: holt ALT while closing the window to tell mozilla not to 
open another window on exit.

Reproducible: Always

Steps to Reproduce:
1. open http://204.177.92.193/pt/affdd/index_de3.jhtml?pin=504144
2. close the site
3. it returns.
> Suggested solution 1: One should be able to never allow mozilla to open a 
> window "on exit". 

Preferences > Advanced > Scripts & Windows

Uncheck "open unrequested windows".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

16 years ago
Of course you can tell mozilla not to open any unrequested windows. However,
even if you want mozilla to open unrequested windows, it should be possible to
forbid mozilla not to open windows "on exit" because there is no useful
application for this "on exit" feature, and it's very annoying.

It's just a feature request; make out of it whatever you want.

Regards,
Klaus
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

16 years ago
->JS Engine
Assignee: asa → rogerl
Component: Browser-General → JavaScript Engine
OS: Windows 2000 → All
QA Contact: asa → pschwartau
Hardware: PC → All
Summary: Javascript "on Exit": no way to escape from page that has itself as "on exit" → Ability to disable Javascript "on Exit"

Comment 4

16 years ago
not JS Engine; ---> Preferences
Assignee: rogerl → ben
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → Preferences
Ever confirmed: true
QA Contact: pschwartau → sairuh
Mass reassign of my non-Firefox bugs to ben_seamonkey@hotmail.com
Assignee: bugs → ben_seamonkey
(Reporter)

Comment 6

15 years ago
(I reported that bug quite a time ago; when there was no "popup blocker").

As there is a good popup blocker in mozilla now, this problem is solved for
everyone having it activated. However, people who explicitely want to allow
popups  will have problems if they are accidently lead to a dialer-site that
extensively uses "on exit" popups. 

As - in contrast to normal popups - I don't see _any_ useful usage of an "on
exit" popup, this should be an extra option which is disabled by default.

Regards,
Klaus
Product: Browser → Seamonkey
Assignee: ben_seamonkey → prefs
QA Contact: bugzilla
(Filter "spam" on 'prefs-nobody-20080612'.)
Assignee: prefs → nobody
QA Contact: prefs
You need to log in before you can comment on or make changes to this bug.