mail filters based on content-type broken in 1.2.1

RESOLVED FIXED

Status

MailNews Core
Filters
RESOLVED FIXED
16 years ago
10 years ago

People

(Reporter: Don Erway, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2.1) Gecko/20021130

I get tons of asian junk mail.

Under moz 1.1, I had filters like
          Content-type contains ks_c_5601 delete.
          Also euc-kr, big5, GB2312, etc.
This worked fine, under 1.1.

Under 1.2.1, these never, or rarely work.  Perhaps because of the "'s or
new-lines that are typically in the content type field..??

I'll send along an example email message, that isn't getting filtered, if desired.





Reproducible: Always

Steps to Reproduce:
1. setup filter field content-type
2. create rule to delete message when content-type contains ks_c_5601
3. receive junk mail, and watch filter fail.
(Reporter)

Comment 1

16 years ago
It seems to only fail, when the content-type field has been broken into
a mail header continuation line.
(Reporter)

Comment 2

16 years ago
Well, I was getting several asian spams per week, that didn't get filtered, even
though they had "ks_c_5601" in a multi-line content-type field.

But since I reported this, I haven't gotten any more, to send in.

(Reporter)

Comment 3

16 years ago
Who cares now?  Moz 1.3b junk mail is working just fine.
Close this.

Fixed in 1.3...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.