Crash if selecting autocomplete value for login and then tab to password field

VERIFIED DUPLICATE of bug 184202

Status

()

Firefox
Address Bar
--
critical
VERIFIED DUPLICATE of bug 184202
15 years ago
15 years ago

People

(Reporter: cerdo, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

This I have noticed on typical "login" forms, but I guess is extensible to any
other similar kinds of web forms.
When I select an autocomplete value for a field and then tab to the next field,
it crashes.

Reproducible: Sometimes

Steps to Reproduce:
1. Open a phoenix window and go somewhere
2. Open a second phoenix window and browse to a web page with a login form (ie.
http://mail.yahoo.com)
3. On the second phoenix window I start typing my login in the login field
4. Phoenix displays the corresponding autocomplete value for the login i am typing
5. I press the "Cursor Down" key in order to select the displayed autocomplete
option
6. I press the tab key, because I want to jump to the password field

Actual Results:  
CRASH !!! There goes the typical Windows 2000 crash window displaying something
like "phoenix.exe has generated blah blah blah", and good bye to all my phoenix
windows.

Expected Results:  
Not crash, select the autocomplete value for the login field and place the
cursor at the password field.

I have noticed this seems to only happen on "child" phoenix windows. That is, if
I try to reproduce it in the first phoenix window I open, it won't happen. It
only happens when I am working with n>1 phoenix windows, and only on the second,
third, etc. phoenix window I have opened, but not on the first one.
By the way... awesome browser. My favorite now.

Comment 1

15 years ago
Attempting to shorten summary.
Summary: Crash if I select the autocomplete value for a login and then tab to the password field → Crash if selecting autocomplete value for login and then tab to password field

Comment 2

15 years ago
This works fine for me.  Have you tried a current build?  Sure, you may not be
able to install any extensions, but it might fix this bug. ;)

Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3a) Gecko/20030120 Phoenix/0.5

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 184202 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.