Last Comment Bug 190324 - Domain Guessing trumps "No Proxy" of hostnames
: Domain Guessing trumps "No Proxy" of hostnames
Status: RESOLVED WONTFIX
:
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: x86 Windows 98
: -- minor (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Patrick McManus [:mcmanus]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-23 10:32 PST by benc
Modified: 2016-01-08 08:13 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description benc 2003-01-23 10:32:06 PST
While working on invalidating bug 154798, I noticed the following that I had not
noticed before:

No proxy does a string match on the suffix of the URL hostname, before I had
thought it might do a simple string match anywhere.

This means that, although you cannot do block single hostnames (w/o an fqdn) by
putting in the default domain of your system into "No proxy", you can block
individual hostnames by simply putting the hostname into "No proxy".

One problem with this setup is that if you have some kind of connection failure,
Domain Guessing (and probably Internet Keywords as well) will pickup on the
failure, and redirect Necko to attempt to connect to http://www.hostname.com.
Since "no proxy" will not catch hostname on a suffix match, this will most
likely go out to the proxy.

Besides the usual level of badness associated with Domain Guessing, this is
additonally too clever, because if a user put a hostname into "no proxy", you
would assume that they are inherently declaring that they expect the host to be
on and available on the local network. If this connection were to fail, that
should be the end of the chain of events. How is asking a proxy for help going
to matter when I already said it is here?!

Realistically, I don't think this is worth fixing, because we would have to
create a no-proxy flag that gets sent to docshell to supress domain guessing if
it matched no-proxy. That is too much thinking for something that just needs to
be turned off.

This analysis, however, might help explain some really weird behaviors in dupes
of bug 91587.
Comment 1 Doug Turner (:dougt) 2003-01-26 01:42:27 PST
--> darin
Comment 2 Darin Fisher 2006-06-20 13:20:42 PDT
-> default owner

Note You need to log in before you can comment on or make changes to this bug.