Include gdiplus.dll in SVG / GDI+ builds

RESOLVED FIXED

Status

()

Core
SVG
--
enhancement
RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: James Graham, Assigned: david avery)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030117
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030117

Windows GDI SVG builds have been missing gdiplus.dll found in earlier builds.
This problem was first noticed around 10-12th January. Without the file Mozilla
will hang at the splash screen. Copying the file from an older installation into
the bin directory allows mozilla to load as normal.

See here for more information http://www.mozillazine.org/forums/viewtopic.php?t=4479

Reproducible: Always

Steps to Reproduce:
(Assignee)

Comment 1

15 years ago
mine
Assignee: alex.fritze → daa
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

15 years ago
my build automation should now include gdiplus.dll - 


reopen if it's missing
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

15 years ago
gdiplus.dll seems to be missing from builds again. I had to install it manually
for 2003032809/win98 and it was missing for previous builds as well. Having read
the build instructions for the SVG build, I'll resummarise this bug as an
encahncement, and file another bug about the fact that Mozilla just hangs at the
splash screen if gdiplus.dll is missing (I tried several builds and assumed they
were broken before I remembered this issue existed at all).
Severity: critical → enhancement
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: SVG / GDI+ builds missing gdiplus.dll → Include gdiplus.dll in SVG / GDI+ builds
(Reporter)

Comment 4

15 years ago
Filed bug 199771 on the lack of an error message.
(Assignee)

Comment 5

14 years ago
until i screw up the automation again this is fixed
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.