bookmark titles too long in Bookmarks menu

VERIFIED DUPLICATE of bug 183944

Status

Camino Graveyard
Bookmarks
VERIFIED DUPLICATE of bug 183944
15 years ago
15 years ago

People

(Reporter: Damon Muller, Assigned: Simon Fraser)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021220 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021220 Chimera/0.6+

The items in the Bookmarks menu show the full title of the bookmark, which is
often quite long. As a result, when you move into a submenu, the titles will
often obscure the top-level menu items when they can't fit in the space to the
right of the menu. This makes it almost impossible to browse down the menu items
(in OS X, the sub menus pop up pretty quickly) if you have a sub-menu with a few
long-titled bookmarks.

Mozilla (tested on 1.2.1 on OS X) does this correctly, by shortening the middle
of the bookmark title as needed on the menu.

Bookmark browsing, especially with the ibook's trackpad, is very much a matter
of hoping you have hit the right spot in the menu before a sub-menu pops up and
blocks the rest of the top-level menu. ie., this severely impacts on the
usability of Chimera for me.

PS. Please don't tell me just to use the bookmarks sidebar. It is slow to
navigate and takes up too much screen real estate on the ibook's 1024x768 screen.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 183944 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
v dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.