Status

()

Firefox
General
--
enhancement
VERIFIED WONTFIX
16 years ago
15 years ago

People

(Reporter: amutch, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)
Build Identifier: 

This patch creates this preference:

user_pref("browser.kiosk_mode", true);

which when set to "true" allows Phoenix to be run in a Fullscreen Kiosk mode. 
It hides all of the chrome and disables shortcut keys except for ALT-F4 which 
closes the browser. This has only been tested on Windows. 

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

16 years ago
Created attachment 112658 [details] [diff] [review]
Fullscreen Kiosk patch
(Reporter)

Comment 2

16 years ago
Forget to add that this works with the current nightly. With 0.5, it's a 
little glitchy. 

Comment 3

16 years ago
amutch: since few people will need this valuable feature, I think the best would
be to create a kiosk extension that you could maintain.
(Reporter)

Comment 4

16 years ago
I've made an extension available here:

http://tln.lib.mi.us/~amutch/pro/phoenix/fullscreen.htm

As I noted at Mozillazine, this is a standard feature in Netscape 4 (-k and -
sk modes) and IE (-k mode) so I tend to view it as a standard feature, not an 
add-on. 

I would note that I've been contacted by several people (libraries, museums, 
etc.) who are looking to use Phoenix if this feature is available. I'll try to 
work with Jessica to keep the code up-to-date but I'm not a coder so I'm not 
sure if I could be the one to keep this going. Thanks for considering it.

Comment 5

16 years ago
I've spoken with the developers and this is not going to be incorporated into
Phoenix. Thanks for the great extension though. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 6

15 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.