Set downloaded file's date-timestamp to match that on the server like wget does

RESOLVED DUPLICATE of bug 178506

Status

enhancement
RESOLVED DUPLICATE of bug 178506
17 years ago
2 years ago

People

(Reporter: j011112mz, Assigned: bugzilla)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

When I download a file, it sets its date to the current time.  It would be much
more useful if it set the time stamp to the same value as on the server (when
this is possible).  Then it would be much easier to tell which files are newer
than similarly named other files, possibly downloaded at different times or from
different mirrors or sites.  The GNU wget tool does this very nicely... just use
the same algorithm.  I often abort a download, copy its URL and redo it with
wget just to get the date set properly.  But, this is very tedious to do.  The
same could be done for saving html pages: set the html file's date to the same
value as on the server.

Reproducible: Always

Steps to Reproduce:
1. Download a file or save a page (ctrl-s).
2.
3.

Actual Results:  
Date of the saved file is the current time.

Expected Results:  
Would prefer the timestamp on the file be set to the time/date specified by the
server.

None.

*** This bug has been marked as a duplicate of 178506 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.