uncloseable tab - last tab on list cannot be closed, also tabs are opening in the wrong place

RESOLVED DUPLICATE of bug 137477

Status

SeaMonkey
Tabbed Browser
--
trivial
RESOLVED DUPLICATE of bug 137477
16 years ago
10 years ago

People

(Reporter: resigned, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

Using 1.2.1, I've had no problems for several weeks, and then suddenly just now
I noticed that "open new tab" was opening tabs not at the END Of the tab-list at
the top of the screen, but one palce before the end.

Furthermore, when I came to try and close the last tab (which everything else
was opening in front of), I can click the close button on the tab-bar, but
although the tab-list flickers,nothing else happens.

All other tabs seem to work properly.

It seems as though the variable saying how many tabs there are has become
corrupted - so that I'm attempting to close a tab which mozilla believes doesn't
exist - and so that when I open a new tab, it opens it after the "last" tab,
which happens in fact to be the "second-to-last" tab.

BUT this should be impossible, I suppose, unless there are TWO copies of this
variable - since the code to change tabs, paint them on screen etc, is all
including the phantom tab.

(search on "uncloseable tab" found no dupes of this)

Reproducible: Didn't try

Steps to Reproduce:
1.Just happened spuriously - I doubt I can reproduce (unless it persists after a
restart)
2.
3.

Actual Results:  
c.f details

Expected Results:  
c.f details

Comment 1

16 years ago
Probably bug 137477. If you see this again, see if there are any errors in the
javascript console.

Comment 2

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030125

Error: b.webProgress has no properties
Source File: chrome://global/content/bindings/tabbrowser.xml#tabbrowser.addTab()
Line: 45

I do it by middle-clicking on weekly CVS changes. with a chase 1:10 "dead" tab
opened and this error poped. 

When I try to close this tab:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIWebProgress.removeProgressListener]" 
nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame ::
chrome://global/content/bindings/tabbrowser.xml#tabbrowser.removeTab() ::
removeTab :: line 32"  data: no]

Updated

16 years ago
QA Contact: pmac → paw

Comment 3

16 years ago
Ruslan, that js-errormeans you are seeing bug 137477. I think this is a dupe,
but cannot be sure until adam can check for the same js-error.
(Reporter)

Comment 4

16 years ago
I was forced to shutdown (unfortunately) since the non-closing tab happened.
I've found the console, and can see ONE b.webProgress has no properties (so this
may be a dupe?). If the console error log is persistent, then I guess it's a
dupe - but I haven't experienced a repeat since I rebooted, so I dunno. It may
be unrelated, but the console itself seems broken too:

Copy  - is broken (the copy RMB menu option is greyed out over all components)
Scrollbars - are missing
The textfield next to "evaluate" - is unclickable.

Note: The console is hidden in a really DUMB place - I finally found it,
although it took me about 5 minutes. It's something I've wanted to do before (as
well as find the java console, if there is one), but searched through all the
menus, and couldn't find anything. It should IMHO be on the "View" menu - I want
to View the output!

A search of mozilla's help for "console" brings up no matches either.

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 137477 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.