Linkify is triggered incorrectly by text such as "a:a" in message

RESOLVED DUPLICATE of bug 183111

Status

RESOLVED DUPLICATE of bug 183111
16 years ago
14 years ago

People

(Reporter: vkissoyan, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

Using text such as test_id:1234 in a message will cause it to linkify it with
the HREF "id:1234" according to the status bar when hovering.

It seems that any text without a space before and after the colon will be
linkified even if it is not a valid URL. 


Reproducible: Always

Steps to Reproduce:
1. Send message to yourself with "a:a" as the only text
2. Retrieve your message
3. Review the link created by Mozilla Mail upon display

Actual Results:  
a:a was linkified

Expected Results:  
"a:a" is not a valid URL, so it should not trigger the linkify code, and not
allow the user to click on something they thought was a link.

*** This bug has been marked as a duplicate of 183111 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.