Last Comment Bug 190876 - disabled form elements kill dom events
: disabled form elements kill dom events
Status: RESOLVED DUPLICATE of bug 218093
:
Product: Core
Classification: Components
Component: DOM: Events (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Andrew Overholt [:overholt]
Mentors:
http://phoyt.macbox.com/html/disabled...
: 330368 347537 475722 (view as bug list)
Depends on: 100085 218093 234455
Blocks: 347537
  Show dependency treegraph
 
Reported: 2003-01-27 15:35 PST by Philip Hoyt
Modified: 2009-01-28 11:50 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Philip Hoyt 2003-01-27 15:35:06 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721

As seen in the testcase (click on any text field), a disabled form element will
kill onclick events in disabled form elements regardless of whether the event
belongs to the element itself, or whether the event belongs to a container div.
This applies to onMouseover events equally. 

Reading the w3c html spec, it doesn't look to me like this is the intention of
disabled elements. I believe that only their usefulness as elements of the form
is to be disabled, not their ability to handle events at all.

Reproducible: Always

Steps to Reproduce:
1. Open the URL above.
2. Click on each text field

Actual Results:  
The non-disabled text fields will produce alerts when clicked upon. The disabled
ones will not. In Internet Explorer, only the second disabled element will
produce an alert -- the second row has the onclick event in the container while
the first has it in the element itself.

Expected Results:  
I expected Mozilla to behave like Internet Explorer. Also, I think it would be
preferable if all form elements on the test case produced onclick events.
Comment 1 Matthew Schultz 2005-09-27 10:33:16 PDT
Possible Dup of 218093?
Comment 2 Olli Pettay [:smaug] 2006-03-13 12:07:59 PST
*** Bug 330368 has been marked as a duplicate of this bug. ***
Comment 3 Olli Pettay [:smaug] 2006-08-07 01:44:44 PDT
*** Bug 347537 has been marked as a duplicate of this bug. ***
Comment 4 Maris Nartiss 2006-08-08 00:48:33 PDT
*** Bug 347537 has been marked as a duplicate of this bug. ***
Comment 5 Nochum Sossonko [:Natch] 2009-01-28 11:38:22 PST
*** Bug 475722 has been marked as a duplicate of this bug. ***
Comment 6 Nochum Sossonko [:Natch] 2009-01-28 11:43:42 PST
Duping to bug 218093 as there's more information/testcase etc.

*** This bug has been marked as a duplicate of bug 218093 ***

Note You need to log in before you can comment on or make changes to this bug.