Closed Bug 19092 Opened 21 years ago Closed 19 years ago

preferences cut off with larger font sizes

Categories

(SeaMonkey :: Preferences, defect, P3, minor)

x86
All

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9.3

People

(Reporter: conanford, Assigned: bugs)

References

Details

(Keywords: polish)

With Fonts set to Large (125%) from the Windows 95 Display Properties control
panel, the text and buttons in the Preferences dialog box in M11 build overrun
the right hand side and bottom edges. This is due to the box boundary not being
adjusted accordingly for the correct larger font size.
Assignee: shuang → german
I believe this is a known bug. German, do you remember the previous similar
bug's number?
Assignee: german → don
sending to don's app team. Part of the problem might be the use of iFrames which
cannot be size intriniscally. But at least we can set the font size smaller, and
see that we can make it work for the 90% case, leaving some room for
localization. CC'ing bot matt and paul, since they're are knee-deep in prefs XUL
right now!
Assignee: don → matt
Target Milestone: M15
Matt, is this our bug or one for the layout/widget guys?
QA Contact: cpratt → sairuh
spam: in my testing realm, so reassigning qa contact to me, en masse.
Bulk move of all Pref UI component bugs to new Preferences component.  Pref UI 
component will be deleted.
Component: Pref UI → Preferences
Just a note: in my experience, this is not limited to Win95/Large fonts. If I
understand the report correctly, I get the same behavior on NT with small fonts.
This may be because a larger font is used for the edit controls and combo boxes.
Move to M16 for now ...
Target Milestone: M15 → M16
This is a problem in Linux as well... when using larger than normal fonts (for
high res displays) the preference dialog overruns the edge of the dialog box.
It doesn't provide a method to a) resize the dialog box (would be nice) or b)
scroll to view additional content.

Target Milestone: M16 → M18
Move to M21 target milestone.
Target Milestone: M18 → M21
*** Bug 48958 has been marked as a duplicate of this bug. ***
*** Bug 53854 has been marked as a duplicate of this bug. ***
*** Bug 59929 has been marked as a duplicate of this bug. ***
...still a problem?
The only problems I see at the moment (with M18) are with combo boxes whose
initial text overflows the edit box and overwrites part of the arrow button. The
problems manifest with the Modern skin, but not Classic.
Examples:
- "As Attachment" value of the "Forward messages:" item under Mail and
Newsgroups > Message Composition
- "No modifier key" value of the mouse wheel behavior item under Advanced >
Mouse wheel.
In each case, when the arrow button is clicked, the edit box is resized to
accommodate the text.
Other weirdness occurs with NS 6, but you don't want to hear about that.
I see this on the 200121620 build in win2k. The initial dialog box for setting the
default browser is too small and not resizable, and you cannot select the buttons.
That is with the default font.
James, that isn't this bug, that's bug 62955.
Other dialog boxes are too small also. And the properties box that comes up when
you edit a bookmark is always full screen!
James, that isn't this bug, that's bug 62955.
*** Bug 66649 has been marked as a duplicate of this bug. ***
*** Bug 73318 has been marked as a duplicate of this bug. ***
*** Bug 62055 has been marked as a duplicate of this bug. ***
This is not just a Win9x large fonts problem.  This also happens with 100dpi 
fonts on Linux when the monitor is running at 90dpi or so.  It can happen on any 
platform with a theme that slightly increases the font size of the chrome (but we 
have less control over that).

As things stand, at the moment, with the classic theme and a fresh profile, when 
I first open preferences I cannot see the entirety of some pref panels.  So the 
default size needs to either be bigger or be based on the resolution/dpi of the 
monitor.
Keywords: mozilla0.9.1, polish
OS: Windows 95 → All
Summary: With Win95 Large fonts, M11 Preferences dialog box fonts and buttons overrun edges → preferences cut off with larger font sizes
I experience this with the classic theme and with normal fonts.
In win98 build 2001040604, the default size of the Preferences window cuts off
some text boxes.  For example, the Navigator/Internet Search/Search Results box
has it's text cutoff.
The latest build 2001032319 also cuts the fonts off in the URL box --the 
descenders are gone! I am using the aviator theme
I think this bug is a dup of bug 54679, "Prefs Panels should allow for size of 
content (scroll)".
->mcafee, or ben?
Assignee: matt → mcafee
nav pretriage: I think Ben's fixes for 80392 shd make this bug go away also. 
setting tm to mozilla0.9.2. 
Target Milestone: --- → mozilla0.9.2
marking fixed
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
tested on win2k using 2001.05.29.09 comm bits with the Display fonts settings
set to Large Fonts (125%). checked all the panels with both classic and modern,
and they look fine [ie, no clipping]. vrfy'ing.
Status: RESOLVED → VERIFIED
Oh so close...on my Win2K machine with 2001052904, the themes section of the
preferences dialog is not quite right with 8pt Microsoft Sans Serif selected for
message box text and the Classic skin. None of the right-aligned controls have a
border on the right side. It appears that they're too wide and/or improperly
positioned, so the borders get clipped.

The problem is worse with smaller fonts; at 6pt, the Apply [theme] and Uninstall
[theme] buttons are invisible, as is the theme description text. Other
preference sections have problems with tiny fonts, too: the toolbar selection
list in the Navigator section has no drop-down arrow; the "When a new message
arrives" portion of the Mail and Newsgroups section is clipped on the bottom.
(This is not an exhaustive list, but a sample.)

Similar problems occur in the Themes section on the Macintosh with 2001052908,
though more of the content gets clipped than with the Windows version. (Being a
Windows guy, I can't figure out how to change the font size on the Mac, so I'm
using the default.)
reopening per last comment
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
over to ben for a look
Assignee: mcafee → ben
Status: REOPENED → NEW
this is not critical but nice to have. moving to m0.9.3. 
Keywords: nsbeta1+
Target Milestone: mozilla0.9.2 → mozilla0.9.3
This has nothing to do with font size. There's a bug for Themes panel does not
fit (80397). This is due to the sizing of the preview image, not fonts. 

Closing again as fixed. 
Status: NEW → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
okay, vrfy.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.