Can't paste more than 4000 bytes into aterm

VERIFIED DUPLICATE of bug 56219

Status

()

defect
VERIFIED DUPLICATE of bug 56219
17 years ago
17 years ago

People

(Reporter: bwucke+bug, Assigned: mjudge)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

17 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030121
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030121

When trying to copy a large amount of data into aterm (afterstep terminal)
window, I get a single random character instead of the marked text.


Reproducible: Sometimes

Steps to Reproduce:
1. Open Mozilla and Aterm. Open some app in aterm to prevent spamming the shell
(typing 'cat' should suffice)
1. Open a page with a large amount of text in Mozilla. 
2. Select a fairly large chunk of text (over 4000 characters)
3. Press middle mouse button in aterm 

Actual Results:  
Some single random character appears.

Expected Results:  
Whole selected text is being pasted.

I'm not sure whether it's aterm's fault or Mozilla's - anyway, pasting large
amounts of data between xterm and aterm works flawlessly - i.e. if you paste the
data from mozilla into xterm or some other x application first, and then from it
into aterm - it works, only mozilla-aterm pair fails.

I've asked about that on afterstep group and someone confirmed that and
mentioned they saw the same effect with rxvt too.

Comment 1

17 years ago
Please search for a duplicate before you file a new request.

*** This bug has been marked as a duplicate of 56219 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
well counted :)
Verified dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.