{inc} Box model vertical formatting problems

VERIFIED FIXED in M11

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
20 years ago
18 years ago

People

(Reporter: Braden, Assigned: buster)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
Though a previous build of NGLayout nailed this test, it now has a few problems:

1. The floated images are being painted over.
2. The top margin is nolonger present as it should be. (It looks like it is being added to the bottom margin.)

Updated

20 years ago
Status: NEW → ASSIGNED
The top-margin problem is a duplicate of 1583.
The painting problem is similar to bug 2007.

Comment 3

19 years ago
Setting all current Open/Normal to M4.

Comment 4

19 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser

Updated

19 years ago
Summary: Box model vertical formatting problems → Box model vertical formatting problems {incremental reflow}

Comment 5

19 years ago
I've checked in a 90% fix for this - the page now lays out correctly (you have
to trigger a resize reflow to make it do the right thing). Incrementally,
however, it does the wrong thing so I've retitled the bug.
Actually, the text (but not the background -- this is fixed now anyway) overlaying the image is correct behavior, since the floats have zero width since their width is not given.

Updated

19 years ago
Severity: normal → minor
Priority: P2 → P4

Updated

19 years ago
Summary: Box model vertical formatting problems {incremental reflow} → {inc} Box model vertical formatting problems
(Reporter)

Comment 7

19 years ago
David:
I disagree with you about the correct behavior of the text here. It should not
overlay the images. From CSS2:

"10.3.6 Floating, replaced elements
If 'left', 'right', 'margin-left' or 'margin-right' are specified as 'auto',
their computed value is '0'. If 'width' is 'auto', its value is the element's
intrinsic width."

Kipp: Mozilla still isn't behaving correctly as far as the top and bottom
margins are concerned. This does not appear to be an incremental reflow
problem. Should a new bug be filed on this?
You're right.  I could have sworn I looked and the images were within a floated
DIV, rather than floated themselves.  I guess I didn't look.

Hmmm....  I thought this was fixed so width was zero only for non-replaced
content (counting tables as replaced, as they should be, since they have
separate width rules).  It must be going to zero even for replaced content.

This seems to have regressed.  The top margin still disappears on reflow, but
the images now are overwritten again (was that ever fixed?).
I think the behavior of the top margin is correct.  The top margin of #test
should collapse with the margin of BODY through the zero margin, padding, and
border of #testContainer and the zero padding of border of body.  This means
that the height of #testContainer doesn't start until the border top of #test.

See the CSS2 errata:
http://www.w3.org/Style/css2-updates/REC-CSS2-19980512-errata.html
for section 10.6.3, and think about where the height of #testContainer is.

You should put a padding on #testContainer to prevent the collapsing.  NGLayout
handles this correctly.

However, the page still shows incremental reflow problems with the replaced
element float widths.

Comment 10

19 years ago
*** Bug 8466 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Severity: minor → normal
Priority: P4 → P3
Target Milestone: M15 → M11

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 11

19 years ago
The initial reflow and resize reflow now agree.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 12

19 years ago
Based on kipp's comments, marking as verified fixed with the Sept 16th build.

Comment 13

19 years ago
Based on kipp's comments, marking as verified fixed with the Sept 16th build.
You need to log in before you can comment on or make changes to this bug.