view all headers with eml attachments, current message header displayed as part of attachment header

VERIFIED DUPLICATE of bug 200380

Status

MailNews Core
Attachments
VERIFIED DUPLICATE of bug 200380
15 years ago
10 years ago

People

(Reporter: Susan Wilson, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

With "view all headers" and "view attachments inline" set up.  An attachment
that is an email message type 'eml' the display has the current email message
header displayed in a darker shade of gray, almost joined into the attachment
email header and appears to be the attachment email messages actual header. 
This is very confusing.  I thought somehow this person got my "delivered" email
message and attached it to another message and sent it back to me.

Reproducible: Always

Steps to Reproduce:
1.set view all headers, set view attachments inline
2.send an eml type attachment 
3 [review].headers of attached email include headers of current message

Actual Results:  
Email headers of current message appear to be included in the attachment eml
headers section

Expected Results:  
only display the header of the attachment eml file

Comment 1

15 years ago
I can corroborate this, if that helps.  I've seen this happen with another
message/rfc822 attachment.  The Received and etc. headers are that of the
containing message rather than the attachment.  Opening the attachment in a
separate window reveals the difference.

Comment 2

15 years ago
(Duplicate already confirmed, otherwise this would have precedence.)

*** This bug has been marked as a duplicate of 200380 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.