View|Folders needs to be implemented.

RESOLVED INVALID

Status

SeaMonkey
MailNews: Message Display
P2
normal
RESOLVED INVALID
19 years ago
13 years ago

People

(Reporter: waqar, Assigned: Sean Su)

Tracking

({access, polish})

Trunk
access, polish
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: 1 day)

Attachments

(8 attachments)

(Reporter)

Description

19 years ago
Connect to an IMAP server and then select View->Folders to hide the folders, it
does not hide them. The check mark is removed but the folders are still
displayed.

Updated

19 years ago
Assignee: phil → putterman
Summary: Selecting View->Folder does not work → [FEATURE] View|Folders, View|Message do not work

Comment 1

19 years ago
View | Message also doesn't work. Probably not a big surprise at this point :-)

Reassigning to putterman

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Blocks: 10791
OS: Linux → All
QA Contact: lchiang → fenella
Hardware: PC → All

Comment 2

19 years ago
View | Message is covered by http://bugzilla.mozilla.org/show_bug.cgi?id=14106

Updated

19 years ago
Target Milestone: M16

Comment 3

18 years ago
*** Bug 21811 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
View|Message now works.

Updated

18 years ago
Whiteboard: 1 day

Comment 5

18 years ago
Syncing priority with marketing.  Moving to P2 to connote "In" for beta2.
Priority: P3 → P2

Updated

18 years ago
Target Milestone: M16 → M17

Comment 6

18 years ago
[FEATURE] bugs past M16 are OUT for this release.  Marking M20.  If you disagree 
with this action, please help me explain it to the PDT.
Target Milestone: M17 → M20

Comment 7

18 years ago
What is left for this bug?  We can't have menu items which don't work.  Fenella 
- can you check and summarize here?

Comment 8

18 years ago
changing milestone.  This is going to be simple UI.  It's only called a feature 
because it used to be a line item on a schedule.  This will be simple.
Target Milestone: M20 → M18

Comment 9

18 years ago
for the moment nominating for nsbeta3 and polish.  I can't remember the outcome 
of our meeting. Currently there's a My Sidebar menu but not a folders menuitem.  
I know that nbaca's been pulling for this.

changing summary to refer to what's left of this bug.
Keywords: nsbeta3, polish
Summary: [FEATURE] View|Folders, View|Message do not work → View|Folders needs to be implemented.

Updated

18 years ago
Keywords: mail2

Updated

18 years ago
Keywords: mail2 → mail6

Comment 10

18 years ago
mail triage marking [nsbeta3-]
Whiteboard: 1 day → [nsbeta3-]1 day

Comment 11

18 years ago
Sorry for the extra email. Removing mail6 keyword.
Keywords: mail6

Updated

17 years ago
Target Milestone: M18 → ---

Comment 12

17 years ago
I would have a go at this but I don't know what access key to use :-(
F is taken by Folder Character Coding.

Comment 13

17 years ago
for now, make it use a dtd and "" as the access key, i think ew can get intl to 
relinquish f later. [just 2 dtd changes]
Keywords: nsbeta3 → access
Whiteboard: [nsbeta3-]1 day → 1 day

Comment 14

17 years ago
What will be the result of the menu item?  View | Sidebar just removes the
Sidebar but doesn't close the folder pane/sidebar splitter.  Will View | Folders
just remove the Folder pane or will it close the whole splitter?  If it just
removes the folder pane, perhaps we need logic that says if both View | Folders
and View | Sidebar are unchecked, close the splitter.

Comment 15

17 years ago
Is Sidebar part of Mail Folders or its own entity?  If it is its own entity, 
unchecking Mail Folders would remove the Mail Folders but My Sidebar would 
remain and take up the whole left pane.  

As putterman mentioned, would be nice if either Mail Folders or Sidebar was 
already unchecked, and then the user unchecked the other one, the whole left 
splitter went away.

Comment 16

17 years ago
As for the mnemonic, I strongly believe that "Folder Character Coding" should be 
removed since it opens the exact same dialog as "Edit --> (folder) properties. 
Bug 71972.

Comment 17

17 years ago
View Folders is a lot easier on the alternate 3 pane layout because the sidebar 
and folders have their own splitters!

Comment 18

17 years ago
On the alternate layout, everything works as expected.
But the best that I have been able to do on the default layout is this:
View Folders collapses the folder splitter.
If the folder splitter is collapsed then View My Sidebar could be disabled.

There were two problems that stumped me.

If the sidebar and folders are visible and the folders are hidden from the menu
then they can only be shown from the menu. But the alternate layout folders and
the message pane are collapsed rather than hidden and can be shown using the grippy.

If the sidebar and folders are visible and the vertical splitter is collapsed
then what should the menu items do? If the sidebar and folders are hidden from
the menu then what should the vertical splitter do?

The only way I can think of to resolve these problems is to make all view
options always hide the splitters are well instead of just My Sidebar.

Comment 19

17 years ago
Created attachment 28114 [details] [diff] [review]
proposed patch although View|Message/Folders may belong under View|Show

Comment 20

17 years ago
>If the sidebar and folders are visible and the folders are hidden from the menu
>then they can only be shown from the menu. But the alternate layout folders and
>the message pane are collapsed rather than hidden and can be shown using the 
>grippy.

Using the "View" menu item (My Sidebar or Folder Pane) should not just collapse 
the splitter/grippy but should remove the item (My Sidebar or Folder 
Pane) completely.

>If the sidebar and folders are visible and the vertical splitter is collapsed
>then what should the menu items do? 

If the splitters are only collasped (and not removed), the menu items should 
remove them completely.  Selecting the menu item again would cause the splitter 
to reappear in its collapsed state.

>If the sidebar and folders are hidden from
>the menu then what should the vertical splitter do?

If the the sidebar and/or folders are hidden/turned off from the menu item, the 
the vertical splitter should not be visible.

Comment 21

17 years ago
jglick@netscape.com wrote:
> Using the "View" menu item (My Sidebar or Folder Pane) should not just collapse
> the splitter/grippy but should remove the item (My Sidebar or Folder Pane)
> completely.

Does this apply to the message pane as well? Currently there is code that checks
to see if the message pane is collapsed and it would have to be modified to
check to see if it was removed as well.

Comment 22

17 years ago
Ideally, i would think the message pane should work the same as well (currently 
it doesn't, the splitter is always visible).

Comment 23

17 years ago
Created attachment 41777 [details] [diff] [review]
Patch that also hides the message splitter as per jglick

Comment 24

17 years ago
Created attachment 41923 [details] [diff] [review]
Revised patch - I missed some files out :-( Apologies for SPAM.

Comment 25

17 years ago
N.B. This patch doesn't address the sidebar on the standard layout (there is no
problem with the alternate layout). Might need some help from sidebar folks.
Otherwise does anyone want to update this bug appropriately?

Comment 26

17 years ago
Created attachment 42188 [details]
Still trying to figure out what should do what...

Comment 27

17 years ago
Created attachment 42371 [details] [diff] [review]
At last! This is it!

Comment 28

17 years ago
CCing sidebar folks for review of changes to sidebarOverlay files

Comment 29

17 years ago
Created attachment 42541 [details] [diff] [review]
Spoke to soon - diffed wrong files :-( Hope these are OK!

Comment 30

17 years ago
Created attachment 42555 [details] [diff] [review]
Yet more SPAM - bitrot this time, sorry.

Comment 31

17 years ago
Message Pane:
- I agree that the splitter should not be visible when I deselect the msg page
in VIew|Show.
- Also, currently, the subject of the selected message is still shown in the
titlebar of the window, which is confusing (in the taskbar, it looks like
standalone msg window, because the "INBOX" comes so late that it's invisible).
(Lucky, the message doesn't seem to load, when I select in.) If you get a
chance, it would be cool, if you could fix that, too.
I think, both problems are a regression.

Comment 32

17 years ago
Created attachment 44105 [details] [diff] [review]
fix typo and bitrot in previous patch

Comment 33

17 years ago
Ben, this bug is about the folder pane. If you don't like the subject appearing
in the title when the message pane is collapsed you should IMHO file a separate bug.

Updated

17 years ago
Keywords: patch, review

Updated

17 years ago
QA Contact: fenella → laurel

Comment 34

17 years ago
Neil, you've been doing all of the work on this, can I reassign it to you?

Comment 35

17 years ago
reassigning to ssu
Assignee: putterman → ssu
Status: ASSIGNED → NEW

Comment 36

17 years ago
If attachment 56566 [details] [diff] [review] to bug 105542 is checked in this will make this bug 
trivial to fix.
Depends on: 105542

Comment 37

16 years ago
Sigh, this will have to wait until bug 123336 is fixed - there's no point hiding
the folders while doing that breaks mail and news...
Depends on: 123336
The menuitem doesn't exist any more. WONTFIX or WFM.

Comment 39

14 years ago
No longer valid. 
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.