Add accesskeys to the xp filepicker

VERIFIED FIXED in mozilla1.4alpha

Status

--
minor
VERIFIED FIXED
16 years ago
2 years ago

People

(Reporter: piers, Assigned: piers)

Tracking

(Blocks: 1 bug, {access})

Trunk
mozilla1.4alpha
All
Linux
access

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

16 years ago
Add accesskeys to the xp filepicker. Setting OS to Linux, but this affects
anywhere that doesn't have a native filepicker. (Is it possible to force use of
the xp picker?)
(Assignee)

Comment 1

16 years ago
Created attachment 113212 [details] [diff] [review]
Add accesskeys
(Assignee)

Comment 2

16 years ago
Could someone using the xp filepicker check this patch for me? (i've only got 
Windows here).

Comment 3

16 years ago
Tested the patch using solaris nightly 2003012622 on solaris 8/sparc. I created
a new user profile for the test.

Upon selecting File->Open File I get a filepicker dialog. The labels "_L_ook
in:", "File _n_ame:", and "Files of _t_ype:" contain underlined access keys
corresponding to what is listed in filepicker.dtd. The checkbox labelled "Show
hidden files and directories" contains no such underline.

Pressing alt-S toggles the "show hidden..." checkbox. But none of the other
access keys seem to work. Mozilla appears to ignore L, N, or T by themselves or
in any combination with ctrl/alt/shift. I also tried moving the focus to
different controls and then trying the access keys, but no joy.

(Assignee)

Comment 4

16 years ago
The checkbox not being underlined is expected behaviour (bug 68841). The rest 
is not expected.

Aaron, i couldn't find any other bugs that would cause this, any thoughts? :)

Comment 5

16 years ago
I checked out the patch.

The problem is that the <label> elements are missing a control="targetid" attribute.

For example:
      <label value="&textInput.label;" id="textInputLabel" control="textInput"
accesskey="&textInput.accesskey;"/>
      <textbox id="textInput" flex="1" oninput="doEnabling()" 
               onfocus="onTextFieldFocus();"/>

You need the control attribute on the label, so that it knows what it's pointing to.
(Assignee)

Comment 6

16 years ago
Created attachment 113641 [details] [diff] [review]
Add accesskeys

Actually add control attributes this time. Thanks Aaron :)
Attachment #113212 - Attachment is obsolete: true
(Assignee)

Updated

16 years ago
Attachment #113641 - Flags: superreview?(dmose)
Attachment #113641 - Flags: review?(dean_tessman)

Comment 7

16 years ago
I don't see the xp picker on Windows.  Can you post a screenshot w/ the patch?
(Assignee)

Comment 8

16 years ago
Dean, i don't have access to unix at the moment, but you can just open 
filepicker.xul in the browser for the general idea. Is that enough, or do you 
still need a screenshot?
Target Milestone: --- → mozilla1.4alpha
(Assignee)

Comment 9

16 years ago
Created attachment 113956 [details]
Screenshot of changes

Managed to get my hands on a solaris machine for a screenshot...

Comment 10

16 years ago
Comment on attachment 113641 [details] [diff] [review]
Add accesskeys

works for me.  r=me
Attachment #113641 - Flags: review?(dean_tessman) → review+
Comment on attachment 113641 [details] [diff] [review]
Add accesskeys

sr=dmose.  sorry for taking so long to get to this bug.
Attachment #113641 - Flags: superreview?(dmose) → superreview+

Comment 12

16 years ago
Checking in mozilla/xpfe/components/filepicker/res/locale/en-US/filepicker.dtd;
/cvsroot/mozilla/xpfe/components/filepicker/res/locale/en-US/filepicker.dtd,v 
<--  filepicker.dtd
new revision: 1.7; previous revision: 1.6
done
Checking in mozilla/xpfe/components/filepicker/res/content/filepicker.xul;
/cvsroot/mozilla/xpfe/components/filepicker/res/content/filepicker.xul,v  <-- 
filepicker.xul
new revision: 1.49; previous revision: 1.48
done

I checked in for piersc@cogs.susx.ac.uk, fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
QA Contact: petersen → sairuh
spiffy! vrfy'd fixed, 2003.02.27.09 comm trunk, linux rh8.0.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.