MacOSX:non-ascii file name is not displayed correctly in the attachment field

RESOLVED WORKSFORME

Status

MailNews Core
Internationalization
P3
normal
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: marina, Assigned: Frank Tang)

Tracking

({intl, regression})

Trunk
PowerPC
Mac OS X
intl, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
seen on MacOSX10.2 JA(10.1 JA doesn't have a problem)
Steps to reproduce:
- open Mail compose window;
- attach several files ( html,jpg, txt);
//note: the japanese chars are not displayed correctly, file names are shwoing
up correctly in the system "Open" dlgbox
(Reporter)

Comment 1

16 years ago
Created attachment 113246 [details]
this is a screen shot to show the problem
(Reporter)

Updated

16 years ago
Keywords: intl, nsbeta1
(Assignee)

Comment 2

16 years ago
is this regression? what the name should be ?
Status: NEW → ASSIGNED
Priority: -- → P3

Comment 3

16 years ago
i18n triage team: nsbeta1+/adt2
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt2]
(Reporter)

Comment 4

16 years ago
i retract my comments about MacOS10.2 only: it happens on both 10.2 and 10.1
(sorry for the confusion). Also it is problematic for Latin-1 languages as well.
Keywords: regression
Summary: MacOS10.2:Japanese file name is not displayed correctly in the attachment field → MacOSX:non-ascii file name is not displayed correctly in the attachment field
(Reporter)

Updated

16 years ago
Hardware: PC → Macintosh

Comment 5

15 years ago
Marina, could you try again with the latest trunk? I made a change for filename
charset recently.
(Reporter)

Comment 6

15 years ago
still a problem with 2003052705 build on MacOS10.1

Comment 7

14 years ago
Now, Japanese file name is displayed correctly,
but is not converted to composed Unicode.
see bug238717 .

Comment 8

14 years ago
-> WFM
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 9

14 years ago
*** Bug 172488 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.