fragile profile - click "add address to adder-book" or prefs=>mail->composition mozilla freezes

RESOLVED DUPLICATE of bug 169777

Status

MailNews Core
Printing
--
critical
RESOLVED DUPLICATE of bug 169777
15 years ago
10 years ago

People

(Reporter: Don Erway, Assigned: dcone (gone))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

I've been using mozilla, since 0.98, but I am truly sick of the fragility, of
the profiles.

Once every 2-3 weeks, I get something in my profile, that makes mozilla freeze
up, attempting normal operations.

The only way out of it, is to throw out the profile, and start again.

Can someone please tell me what files are most likely the problem?

This is truly aggravating, as the profile is overly tied together- with the
idiotic random string directory, which is included, along with lots of absolute
path names, in prefs.js, etc, to ensure you can't copy a profile and have it work.


Reproducible: Always

Steps to Reproduce:
1.get my profile
2. try to change mail composition preferences or try to add a sender's address
to address book.
3. kill mozilla with task manager, after it locks up at 98% cpu, for as long as
you care to wait.




The whole profile thing needs work - mail settings should be in the mail directory,
so it can be copied, and backed up.  And so I don't have to recreate the
settings by hand, every time my profile goes bad.

Profiles cannot be moved or copied, since they have frickin' absolute path
names.  Give me a break.

Comment 1

15 years ago
Do you follow the installation notes when installing Mozilla?
And are you sure all your addons (in the "chrome" dir, like themes,
spellchecker, language packs or whatever) are compatible with the version of
mozilla that you're running? 

You may you have something onboard that corrupts XUL.mfl.
The file has also become corrupted on crashes now and then - known issue.
It's a cache and can safely be deleted (when mozilla/quicklaunch are not running)

Possible dup of bug 169777

Updated

15 years ago
No longer depends on: 169777
(Reporter)

Comment 2

15 years ago
Thanks for the tip.  I was tearing my hair out, at the thought of once again
having to rebuild profile from scratch, including manually entering all mail &
news accounts, and copying over not much more than the addr book, bookmarks, and
mail files & filters.

Whew.  Deleteing the XUL.mfl fixed everything.

This thing has just about killed me, a dozen times now.  And I do not run funny
plugins.  Only  acrobat, at the moment.  I haven't wanted to invest time in
really setting it up, when it just kept locking up...

I wonder how many people run mozilla, until the first time it locks up, and then
give up?

This should be big in the FAQ and help - "warning, any time things get weird,
the first thing to do, is delete the XUL.mfl"

At least put a README in the profile directory, with a 1 sentence guide of the
files, and what can be flushed.

Otherwise, consier closed.

Comment 3

15 years ago
>I wonder how many people run mozilla, until the first time it locks up, and
>then give up?

The latest nightlies contain a fix for some XUL.mfl corruption problems.

Resolving as dup of bug 169777. You are automatically added to the CC of that
bug and may want to remove yourself again. Much traffic there - 74 dupes and
counting. Indicating that at least *some* of the frustrated users make noises
here in Bugzilla before they throw the towel in for good ;)

*** This bug has been marked as a duplicate of 169777 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.