Closed Bug 191724 Opened 17 years ago Closed 17 years ago

Support fulltext searches

Categories

(Bugzilla :: Query/Bug List, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 145588

People

(Reporter: bbaetz, Assigned: endico)

References

()

Details

(Keywords: perf)

We should look into supporting mysql full text searches for summary/whiteboard
queries, and possibly comments too (depending on index size)

In doing so, we need to bear in mind the mysql restrictions (words <= 3 chars
aren't indexed, no stopword list). Note that we can't use BOOLEAN MODE before
4.0.1, and so we'd need different indexes for each of the columns (see 6.8.1 in
the mysql docs). Combined with OR, it may be that mysql doesn't use the index
anyway, given its known limitations in that area.

We also need to check the size of the index - its likely to be really large over
the comments, for example.

This should be done in a generic way so that postgres can use its tsearch stuff
too. I don't know if sybase has a full text module.

It is _NOT_ a requirement that searches behave identically in all these
databases - the metachars are very different, although the basic 'allwords'
stuff is similar. In particular searching for "foo bar" will find ether of the
words in mysql, stuff with both the words in oracle, and the postgres docs are
too confusing for me to work out what it does :)

*** This bug has been marked as a duplicate of 145588 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.