Closed Bug 19177 Opened 20 years ago Closed 20 years ago

user_pref("string:network.proxy.http", "proxyhost") fails

Categories

(SeaMonkey :: Preferences, defect, P3)

DEC
Linux
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: tomh, Assigned: matt)

References

Details

The default prefs.js file is created with string: labels on the
proxy lines, and the proxy port gets entered with quotes around it.
It doesn't work. In GetIntPref, the "network.proxy.http" name is
marked as 'no user value' and the default gets returned. Same for
the port. Changing the prefs.js file to read:
user_pref("network.proxy.http", "proxyhost");
user_pref("network.proxy.http_port", port); where port is numeric (no quotes)
works. So the bug is either
the fact that the prefs.js file is created with string: labels, or
that libPref doesn't handle them.
QA Contact: paulmac → tever
setting tever has qa contact for proxy bug
Status: NEW → ASSIGNED
Target Milestone: M13
Based on issues, this is a DUP of bug 16274 "Writing out bad proxy prefs" ...
both bugs are ASSIGNED and M13

Is this a "libPref" problem or a "Networking" problem? Guessing "libPref",
so that would make bug 16274 a DUPLICATE of this bug.

According to vidur@netscape.com in bug 16274,
>Both the string: before the pref name and the quotes around the port number
>are bogus. Changing these manually fixed the problem.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Looks like this is case of writing bad proxy prefs from Necko. Marking it a
duplicate of 16274.

*** This bug has been marked as a duplicate of 16274 ***
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Necko doesn't write out any prefs. This is a case of bad prefs being written out

from the preference dialog box. I am correcting this by setting the dup back to

the prefs owner. The other bug is a dup of this one.
*** Bug 16274 has been marked as a duplicate of this bug. ***
Assignee: neeti → matt
Status: REOPENED → NEW
Component: libPref → Pref UI
Reassigning this to Matt. Looks like a Pref UI bug.
QA Contact: tever → sairuh
spam: in my testing realm, so reassigning qa contact to me, en masse.
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
I believe this was fixed a while ago.
This is what my pref wrote out:
user_pref("network.proxy.http", "what");
user_pref("network.proxy.http_port", 99);
my bad: this should prolly go back to tever for verif...
QA Contact: sairuh → tever
Bulk move of all Pref UI component bugs to new Preferences component.  Pref UI 
component will be deleted.
Component: Pref UI → Preferences
verif.
Linux 2000071308
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.