losing body parameters (margins) in html template mails

VERIFIED DUPLICATE of bug 170504

Status

defect
VERIFIED DUPLICATE of bug 170504
17 years ago
11 years ago

People

(Reporter: lion, Assigned: bugzilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

17 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i586; hu-HU; rv:1.0.0) Gecko/20020529
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; hu-HU; rv:1.0.0) Gecko/20020529

There is a way to add additional body tags to HTML template mails in "format" ->
"page properties" -> "advanced". The template is stored with these additional
details in "Tempaltes" but when reusing, these are lost. 

I tried: topmagin=0 bottommargin=0 marginwidth=0 marginheight=0



Reproducible: Didn't try

Steps to Reproduce:
1.Create a html mail with 100% width table
2."Format" - "Page prop" - "Advanced" add extra parameters to BODY tag
3. Store the template (File, Save As, Template"
4. Click twice on the template
Actual Results:  
The tompargin,etc, all parameters from BODY tag are lost

Expected Results:  
Keeping the parameters

This is an old Mozilla, if already fixed, I am sorry.

Comment 1

17 years ago
Please give detailed steps to reproduce the problem. For instance

- Should the cursor appear within the table before going to the Format menu?
2."Format" - "Page prop" (please be specific with the name of this menu item) 
- "Advanced" add extra parameters to BODY tag (what extra parameters specifically?)
Reporter

Comment 2

17 years ago
Sorry for being not enough specific. Here is another screenshot for easier
understanding:

http://c64.rulez.org/~lion/bugs/mozbug12.gif

2. "Fromat" -> "Page colors and background..." -> "Advanced" -> Edit custom tags
for the BODY item. 

Then I set margin values to be 0 and save the template. Thats what you see in
this image, the window in the back. When opened for editing then these margin
values are lost from the BODY tag, we have to set them again before sending out
the mail. 

What tags? These: topmagin=0 bottommargin=0 marginwidth=0 marginheight=0

The expected result, is the possibility of having marginless templates, which
generally means: when opening a template for editing, keep BODY TAGS.

(These tags might be invalid HTML in validators, but they work fine.)

Thanks!

Comment 3

17 years ago
Trunk build 2003-02-05: WinMe, Mac 10.1.5 
Appears to be working as expected.

Please try downloading a newer build. The Mozilla 1.3b build should be available
soon.

Comment 4

16 years ago
Confirmed with Mozilla v1.3 on OS X 10.2.4 and on Win2k-SP3
Please mark for all platforms and all operating systems. 

There is one step missing from the Steps-to-Reproduce: 3b. Quit Mozilla (Accel+Q)

In addition to margins, this bug also affects other body parameters, so please
remove "(margins)" from the summary. This is major limitation for BiDi users
(impossible to create a template with dir="rtl").

Prog.

Comment 5

16 years ago
This appears to be a duplicate of bug 170504.  Ferenc Veres, do you agree?

Comment 6

16 years ago
No response from reporter.

*** This bug has been marked as a duplicate of 170504 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.