All users were logged out of Bugzilla on October 13th, 2018

window.name does not change when going to a different site

RESOLVED INVALID

Status

()

RESOLVED INVALID
16 years ago
15 years ago

People

(Reporter: navidazizi, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030110
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030110

Clicking on the "Instructors" link on the left-hand frame should open the link
in the right-hand frame.  This usually happens, but if you go to
http://www.tsn.ca first, and then go back to
http://courses.ece.utoronto.ca/ece451h1s then the behaviour changes, and the
link is opened up in the whole window.

This seems to be a problem because the right-hand frame on
courses.ece.utoronto.ca/ece451h1s is called "main"

Reproducible: Always

Steps to Reproduce:
1. Go to www.tsn.ca
2. Go to courses.ece.utoronto.ca/ece451h1s
3. Click on the "instructors" link on the left-hand frame

Actual Results:  
The link opens up in the whole window

Expected Results:  
The link should open up in the right-hand frame

Comment 1

16 years ago
Correct. http://www.tsn.ca doing window.name="main", and "instructors" link use
target=main. So this link target whole window. 
Yeah, but I think we should be blowing that away when going to a different site....
Assignee: asa → jst
Status: UNCONFIRMED → NEW
Component: Browser-General → DOM Level 0
Ever confirmed: true
OS: Windows XP → All
QA Contact: asa → desale
Hardware: PC → All

Comment 3

16 years ago
BTW, IE 6.0 have 100% same bug. What stantarts say about this case?
Summary: Link opens in top rather than frame → window.name does not change when going to different cite.
What about NS4.x?
(Reporter)

Comment 5

16 years ago
Same behaviour on NS 4.x, but not in IE 5.0
Mass-reassigning bugs to dom_bugs@netscape.com
Assignee: jst → dom_bugs

Updated

15 years ago
Summary: window.name does not change when going to different cite. → window.name does not change when going to a different site
The standards say nothing. If we're interoperable with other browsers on the
market, then we're doing the right thing.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.