Closed Bug 19194 Opened 21 years ago Closed 21 years ago

Some Fonts displayed by Mozilla11 are wrong..

Categories

(SeaMonkey :: General, defect, P3)

x86
Windows 98
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 991

People

(Reporter: eloli, Assigned: leger)

References

()

Details

Load the above URL with IE4+ or Netscape and you will see that all the
bulletpoint Fonts and the LAST sentence are Arial or Verdana.
However, Mozilla11 is keep using Time New roman...

Also, on http://www.ukbug.org, on the left menu, the verdana font is keep
displaying on size=2 while I have asked for size=1.
 Someone said that I should not use the <FONT>tag at all, and use only CSS, but
this is a page for BeOS, and the native BeOS browser do not support CSS.
So, I need a workaround for this problem.
  You have to put priorities as to if the <FONT>is before or after a <SPAN>tag, so
you give more "power" to the one that is second and "nearer" to the text. As
IE4+ and Netscape4 does...
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
There is code on the page at the above URL that surrounds entire <UL> elements
with <FONT> elements, similar to the following:

   <B><I><FONT SIZE="2" COLOR="#000000" FACE="Arial,Helvetica,Verdana">
   <UL> ... </UL>
   </font></I></B>

If the <FONT> tags are moved inside the <UL>, everything works fine.

For http://www.ukbug.org/, the same problem exists: one <font> element
around many tables.

This looks like yet another DUPLICATE of bug 991. Marking that way.


*** This bug has been marked as a duplicate of 991 ***
verified duplicate of 991 -[DOGFOOD][4.xP] font tags containing blocks are 
'badly' parsed-
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.