[4.xP]Wrong acces to multi-homed sites

VERIFIED FIXED in M14

Status

()

Core
Networking
P3
major
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: hub, Assigned: Gagan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
With Mozilla M11 Linux glbic 2.1

When I try to access to a multi-homed site on Webstar servers, I can't get it.
Examples are http://www.frbug.org/ or http://www.bcdl.com/
You get the MAIN domain homepage instead.

Updated

19 years ago
Version: other

Comment 1

19 years ago
Fixing bugzilla database corruption.
Assignee: leger → gagan
Component: Browser-General → Networking-Core
Summary: Wrong acces to multi-homed sites → [4.xP]Wrong acces to multi-homed sites
I see this on Linux mozilla 1999-12-02-16-M12.  I'm not sure what the cause is.
Mozilla does seem to be sending the "Host" HTTP header (based on
http://www.fas.harvard.edu/~dbaron/www/httpreq ).

Could you be doing a reverse DNS lookup and using that hostname instead?  That's
wrong...

Changing component to Networking-Core and reassigning.

(BTW, a little more detail on the testcase:  www.frbug.org maps to an IP address
whose primary hostname is secure.zarcrom.net .  http://secure.zarcrom.net/ is a
simple page that has a META refresh that redirects to http://www.zarcrom.net/ .)

STEPS TO REPRODUCE:
 * load http://www.frbug.org/ in mozilla

EXPECTED RESULTS:
 * the page http://www.frbug.org/ loads (the French Be Users Group, or
something...)

ACTUAL RESULTS:
 * http://www.zarcrom.net/ loads

DOES NOT WORK CORRECTLY ON:
 * Linux mozilla 1999-12-02-16-M12

WORKS CORRECTLY ON:
 * Linux NN 4.7

Comment 3

19 years ago
I think this is a dup of bug 14431

Comment 4

19 years ago
Mass move of all bugs without target milestones to M13.

Comment 5

19 years ago
Resetting QA Contact.

Comment 6

19 years ago
Bulk move of all Networking-Core (to be deleted component) bugs to new
Networking component.

Updated

19 years ago
Target Milestone: M13 → M14
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

19 years ago
Fix checked in. This was happening because of lower case "Host:" header. See bug
20814

Comment 8

19 years ago
verified:
Linux 2000042709
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.