page consumes %99 of CPU time after loading

RESOLVED DUPLICATE of bug 216430

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 216430
16 years ago
14 years ago

People

(Reporter: Ahmet A. Akin, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030204
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030204

After entering the page, it loads and everything becames very sluggish. mozilla
starts consuming %99 of CPU time. it is same in other pages in the site.

Reproducible: Always

Steps to Reproduce:
1. enter the page.
2.
3.

Actual Results:  
mozilla eats up CPU

Comment 1

16 years ago
WFM with Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.3b) Gecko/20030204
(Reporter)

Comment 2

16 years ago
i understand that, for making this situation happen, you should scroll the page
up and down for a while. 

Comment 3

16 years ago
Confirming the problem:

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030205

92+% after scrolling by dragging the scrollbar, scrolling without dragging the
scrollbar still increases the load somewhat but less than 30% on my system.

The same thing happens using Netscape 7.01, so it doesn't appear to be a
Trunk-induced problem.

Comment 4

16 years ago
WFM - current CVS based trunk build - WinXP-Sp1.

Comment 5

16 years ago
May be a video card incompatibilty, I using an ATI Radeon 9500 Pro?
(Reporter)

Comment 6

16 years ago
also in my home i have an XP machine with a RADEON 8500LE, mozilla (20021218)
has the same problem. But the one in the bug report, has a graphic card other
than Radeon. i also tried that in another, much older machine with phoenix, has
the same problem. 

Comment 7

16 years ago
I have Win2k SP3, Mozilla Gecko/20030206 (The about: page incorrectly reports
Gecko/20030203, thought I saw a bug on that one) and Phoenix Gecko/20021207 on a
Compaq Presario 2274.
Both Mozilla and Phoenix jump to about 99% CPU power than the both drop down
normal levels (=between 0% and 8% for Phoenix while typing this message using
Mozilla. Mozilla and Phoenix both use way too mch cpu cycles while doing
nothing, why is that? Is that being worked on, has it even been filled?) 

Comment 8

16 years ago
Another confirmation using:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210
If I scroll part-way down the page, utilization jumps to 99%, then settles at
about 65-70%.  If I continue scrolling, utilization jumps back to 99% and stays
there until I close the tab/browser window that is showing the page.

Comment 9

15 years ago
Reporter: Can you reproduce this bug with a recent build of Mozilla (for
example, 1.4rc3)? 

If so, then please comment again with details. 
If not, then please resolve this bug as WORKSFORME. Thanks.

Comment 10

15 years ago
Some CPU usage stats for the following versions of Firebird and Moz1.4:
FB: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030611
Mozilla Firebird/0.6
RC3: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

System: Duron 1.2GHz, W2K SP3, Matrox G400


http://www.trekweb.com
FB: starts off 10-25%, scrolling slow and jerky, pressing and holding scrollbar
arrow causes usage to go to 99% and scrolling is very slow, after letting go
usage remains at 60-80%.
RC3: 2%, scroll down to bottom of page using scrollbar arrow, then up and down
again - usage goes up to 40 - 50%. Scroll back to top of page, usage 80-95%.
Reload - usage goes back to 2%. Scrolling ups the usage again. Hence I can
reproduce bug on 1.4rc3.
IE5.5: 0%

Both FB and RC3 slow down noticeably when scrolling is revealing the images at
the bottom left corner of the page - specifically the "ST Nemesis DVD" and "ST:
VOY Companion" images which are displayed on page *at reduced size*.

Comment 11

15 years ago
Could anyone who commented in this bug please try a recent Mozilla build and let
us know if it has been fixed? I am 99% sure that what you are experiencing here
is bug 216430, which was fixed within the last month. Thanks for any help, if I
don't hear back from anyone on this I'll mark it as a dupe.

Comment 12

15 years ago
Still happens with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b)
Gecko/20030917.
(Reporter)

Comment 13

15 years ago
With latest firebird there seems no problem now. Win XP Pro Radeon 8500LE

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030917
Firebird/0.6.1+

Comment 14

15 years ago
Hmm...I did a little more testing, and the site does still consume a lot of CPU
time while scrolling. It does seem better than before though...even though it is
using most of the CPU power, where it used to make the site almost unusable, I
can now scroll somewhat smoothly and actually click links.

I still think that this is a dupe of bug 216430, especially after reading the
later comments in that bug that say there is still work to be done to completely
fix the problem. I guess they only put in a "band aid" patch that helps but does
not eliminate the bug, and further work will go on in 218861. I'm going to mark
this as a dupe, but if anyone disagrees feel free to reopen this or comment in
the other bugs. Thanks.

*** This bug has been marked as a duplicate of 216430 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.