Mozilla does not start at all

RESOLVED DUPLICATE of bug 196062

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 196062
15 years ago
13 years ago

People

(Reporter: Martin Mokrejs, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.78 [en] (X11; U; OSF1 V5.1 alpha)
Build Identifier: 

Hi,
  I've compiled cvs checkout 20030205 on Tru64Unix 5.1A with cc/cxx version
6.5-033. I used full debugging CFLAGS, so if you want I can debug something.


$ /afs/gsf.de/alpha_dux51/usr/mozilla-1.3b/bin/mozilla
No Persistent Registry Found.
Type Manifest File:
/afs/gsf.de/@sys/usr/mozilla-1.3b/lib/mozilla-1.3b/components/xpti.dat
nsNativeComponentLoader: autoregistering begins.
###!!! ASSERTION: no native to utf-8 converter: 'gNativeToUTF8 !=
INVALID_ICONV_T', file nsNativeCharsetUtils.cpp, line 275
Break: at file nsNativeCharsetUtils.cpp, line 275
###!!! ASSERTION: no utf-8 to native converter: 'gUTF8ToNative !=
INVALID_ICONV_T', file nsNativeCharsetUtils.cpp, line 282
Break: at file nsNativeCharsetUtils.cpp, line 282
*** Registering nsTestDynamicModule components (all right -- a generic module!)
*** Registering MyService components (all right -- a generic module!)
*** Registering nsSampleModule components (all right -- a generic module!)
*** Registering xpconnect components (all right -- a generic module!)
*** Registering xpconnect_test components (all right -- a generic module!)
*** Registering nsUConvModule components (all right -- a generic module!)
*** Registering nsUCvMathModule components (all right -- a generic module!)
*** Registering nsI18nModule components (all right -- a generic module!)
*** Registering nsJarModule components (all right -- a generic module!)
*** Registering JavaScript_Debugger components (all right -- a generic module!)
*** Registering necko_core_and_primary_protocols components (all right -- a
generic module!)
*** Registering necko_secondary_protocols components (all right -- a generic
module!)
*** Registering nsURILoaderModule components (all right -- a generic module!)
*** Registering nsPrefModule components (all right -- a generic module!)
*** Registering nsCJVMManagerModule components (all right -- a generic module!)
*** Registering nsSecurityManagerModule components (all right -- a generic
module!)
*** Registering nsChromeModule components (all right -- a generic module!)
*** Registering nsRDFModule components (all right -- a generic module!)
*** Registering nsParserModule components (all right -- a generic module!)
*** Registering nsGfxPSModule components (all right -- a generic module!)
*** Registering nsGfxGTKModule components (all right -- a generic module!)
*** Registering nsGfxXprintModule components (all right -- a generic module!)
*** Registering nsMNGDecoderModule components (all right -- a generic module!)
*** Registering nsImageLib2Module components (all right -- a generic module!)
*** Registering nsPluginModule components (all right -- a generic module!)
*** Registering javascript__protocol components (all right -- a generic module!)
*** Registering DOM_components components (all right -- a generic module!)
*** Registering nsViewModule components (all right -- a generic module!)
*** Registering nsWidgetGTKModule components (all right -- a generic module!)
*** Registering XRemoteClientModule components (all right -- a generic module!)
*** Registering nsLayoutModule components (all right -- a generic module!)
*** Registering nsMorkModule components (all right -- a generic module!)
*** Registering docshell_provider components (all right -- a generic module!)
*** Registering nsProfileModule components (all right -- a generic module!)
*** Registering nsPrefMigrationModule components (all right -- a generic
module!)
*** Registering embedcomponents components (all right -- a generic module!)
*** Registering Browser_Embedding_Module components (all right -- a generic
module!)
*** Registering "EmbedLite components" components (all right -- a generic
module!)
*** Registering nsEditorModule components (all right -- a generic module!)
*** Registering nsTransactionManagerModule components (all right -- a generic
module!)
*** Registering nsComposerModule components (all right -- a generic module!)
*** Registering nsAccessibilityModule components (all right -- a generic
module!)
*** Registering nsLDAPProtocolModule components (all right -- a generic module!)
*** Registering appshell components (all right -- a generic module!)
*** Registering nsFileViewModule components (all right -- a generic module!)
*** Registering nsFindComponent components (all right -- a generic module!)
*** Registering nsRegistryViewerModule components (all right -- a generic
module!)
*** Registering Session_History_Module components (all right -- a generic
module!)
*** Registering XRemoteServiceModule components (all right -- a generic module!)
*** Registering application components (all right -- a generic module!)
*** Registering nsSoftwareUpdate components (all right -- a generic module!)
*** Registering nsCookieModule components (all right -- a generic module!)
*** Registering nsWalletModule components (all right -- a generic module!)
*** Registering nsWalletViewerModule components (all right -- a generic module!)
*** Registering nsXMLExtrasModule components (all right -- a generic module!)
*** Registering nsAutoConfigModule components (all right -- a generic module!)
*** Registering TransformiixModule components (all right -- a generic module!)
*** Registering nsInspectorModule components (all right -- a generic module!)
*** Registering nsUniversalCharDetModule components (all right -- a generic
module!)
*** Registering nsTypeAheadFind components (all right -- a generic module!)
*** Registering BOOT components (all right -- a generic module!)
*** Registering NSS components (all right -- a generic module!)
*** Registering PKI components (all right -- a generic module!)
*** Registering nsMsgBaseModule components (all right -- a generic module!)
*** Registering nsMsgDBModule components (all right -- a generic module!)
*** Registering nsMsgNewsModule components (all right -- a generic module!)
*** Registering local_mail_services components (all right -- a generic module!)
*** Registering nsMimeEmitterModule components (all right -- a generic module!)
*** Registering nsVCardModule components (all right -- a generic module!)
*** Registering mime_services components (all right -- a generic module!)
*** Registering nsMsgComposeModule components (all right -- a generic module!)
*** Registering IMAP_factory components (all right -- a generic module!)
*** Registering nsAbModule components (all right -- a generic module!)
*** Registering nsImportServiceModule components (all right -- a generic
module!)
*** Registering nsTextImportModule components (all right -- a generic module!)
*** Registering nsComm4xMailImportModule components (all right -- a generic
module!)
*** Registering nsAbSyncModule components (all right -- a generic module!)
*** Registering nsMsgMdnModule components (all right -- a generic module!)
*** Registering nsMsgMailViewModule components (all right -- a generic module!)
*** Registering nsBayesianFilterModule components (all right -- a generic
module!)
*** Registering nsMsgSMIMEModule components (all right -- a generic module!)
nsNativeComponentLoader: autoregistering succeeded
WARNING: Trying to set p, file prefapi.cpp, line 1017
*** Deferring registration of sample JS components
*** Registering -chat handler.
*** Registering x-application-irc handler.
*** Registering irc protocol handler.
*** Registering mdn account manager extension.
*** Registering smime account manager extension.
nNCL: registering deferred (0)
*** Registering sample JS components
nNCL: registering deferred (0)
nNCL: registering deferred (0)
nsNativeComponentLoader: autoregistering begins.
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)
*** Chrome Registration of package: Checking for contents.rdf at
jar:resource:/chrome/comm.jar!/content/communicator/
*** Chrome Registration of locale : Checking for contents.rdf at
jar:resource:/chrome/en-US.jar!/locale/en-US/communicator/
###!!! ASSERTION: failed to create encoder: '0', file nsUNIXCharset.cpp, line
368
Break: at file nsUNIXCharset.cpp, line 368
###!!! ASSERTION: unable to use nl_langinfo(CODESET): '0', file
nsUNIXCharset.cpp, line 292
Break: at file nsUNIXCharset.cpp, line 292
###!!! ASSERTION: unable to convert locale to charset using deprecated config:
'0', file nsUNIXCharset.cpp, line 125
Break: at file nsUNIXCharset.cpp, line 125
WARNING: nsXKBModeSwitch::ControlWorkaround:, file nsKeyboardUtils.cpp, line 78
WARNING:     grab_during, file nsKeyboardUtils.cpp, line 79
WARNING:     ungrab_duri, file nsKeyboardUtils.cpp, line 80
WARNING: 

nsXKBModeSwitch::HandleMappingNotify: no Mode_switch

, file nsKeyboardUtils.cpp, line 155
WARNING: 

nsXKBModeSwitch::HandleMappingNotify:, file nsKeyboardUtils.cpp, line 157
WARNING:     gModeSwitch, file nsKeyboardUtils.cpp, line 158
WARNING:     gModeSwitch, file nsKeyboardUtils.cpp, line 159
GFX: dpi=116 t2p=0.0833333 p2t=12 depth=16
WEBSHELL+ = 1
IsPluginFile(/afs/gsf.de/@sys/usr/mozilla-1.3b/lib/mozilla-1.3b/plugins/libnullplugin.so)
== TRUE
LoadPlugin()
/afs/gsf.de/@sys/usr/mozilla-1.3b/lib/mozilla-1.3b/plugins/libnullplugin.so
returned 140139510
GetMIMEDescription() returned "*:.*:All types"
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file nsChromeRegistry.cpp,
line 3141
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file nsChromeRegistry.cpp,
line 3141
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file nsChromeRegistry.cpp,
line 3141
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file nsChromeRegistry.cpp,
line 3141
###!!! ASSERTION: failed to Ensure1Window: 'NS_SUCCEEDED(rv)', file
nsAppRunner.cpp, line 1240
Break: at file nsAppRunner.cpp, line 1240
nsPluginHostImpl::Observe "xpcom-shutdown"
WARNING: nsExceptionService ignoring thread destruction after shutdown, file
nsExceptionService.cpp, line 189
WARNING: NS_ENSURE_TRUE(uriLoader) failed, file nsDocShell.cpp, line 378
WARNING: Failed to create timer, file nsJSEnvironment.cpp, line 1622
nsPluginHostImpl dtor
WEBSHELL- = 0
*** Unloading sample JS components
JS engine warning: 37 atoms remain after destroying the JSRuntime.
                   These atoms may point to freed memory. Things reachable
                   through them have not been finalized.
###!!! ASSERTION: Component Manager being held past XPCOM shutdown.: 'cnt == 0',
file nsXPComInit.cpp, line 769
Break: at file nsXPComInit.cpp, line 769
###!!! ASSERTION: can't get memory manager!: 'gMemory', file nsMemory.cpp, line
58
Break: at file nsMemory.cpp, line 58
###!!! ASSERTION: can't get memory manager!: 'gMemory', file nsMemory.cpp, line
58
Break: at file nsMemory.cpp, line 58
###!!! ASSERTION: can't get memory manager!: 'gMemory', file nsMemory.cpp, line
58
Break: at file nsMemory.cpp, line 58
###!!! ASSERTION: can't get memory manager!: 'gMemory', file nsMemory.cpp, line
58
Break: at file nsMemory.cpp, line 58
$

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 196062 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.