Import 4.x Address Book and no cards/lists display

VERIFIED FIXED

Status

MailNews Core
Import
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: Cavin Song, Assigned: Cavin Song)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

16 years ago
This is for bugscape bug 17509.

Overview: Import a 4.x Address Book (any *.na2 file) and the address book name
appears in the directory pane but the results pane is blank.

Steps to reproduce:
1. Select Tools|Import
2. Select Address Book radio button
3. Select Communicator 4.x
4. Go to a 4.x User's profile directory and select any *.na2 file

Actual Results: The name of the address book appears in the dir pane but the
results pane is blank (no cards or lists display). Even after a restart the
results pane is still blank.

Tried turning Quick Launch on or off and in both cases it did not work.

Compared abook.mab files between the trunk and the branch builds. The trunk
build has less information. If interested I can send you the files.

The problem occurs in a simple case. In 4.x I created a new profile with one
card (First Name, Last Name, Email Address), remigrated and also tried importing
but still blank.

Expected Results: The cards/lists should display

Additional Information:
1. Trunk 2002-07-08: Mac X and Linux = ok
2. Branch 2002-07-08, WinMe with Quick Launch on or off = ok

I would fix this bug in two stages because I was not able to reproduce it in 
debug mode (which I needed most). But there is a problem in displaying error 
messages in the import result dialog when import finishes. Right now the entire 
dialog is empty and there's no clue on what could have caused the problem.

The following patch would make it so that error messages will show up at the end 
of the import and from there hopefully we can have some ideas about the 
error(s).

I would leave this bug open after the patch is checked in and only close it when 
the real problem is fixed.


------- Additional Comment #8 From Cavin Song 2003-01-28 16:19 ------- 

Created an attachment (id=10135)
Fixed error msgs display problem.

First stage of the fix (to help us locate the problem).


------- Additional Comment #9 From Seth Spitzer 2003-01-28 23:44 ------- 

(From update of attachment 10135 [details])
sr=sspitzer
(Assignee)

Comment 1

16 years ago
Created attachment 113712 [details] [diff] [review]
Fixed error msgs display problem.

First stage of the fix (to help us locate the problem).
(Assignee)

Comment 2

16 years ago
Comment on attachment 113712 [details] [diff] [review]
Fixed error msgs display problem.

Need this patch to help us locate the problem.
Attachment #113712 - Flags: approval1.3b?

Comment 3

16 years ago
Comment on attachment 113712 [details] [diff] [review]
Fixed error msgs display problem.

We're trying to get beta out the door ASAP. This is going to have to wait.
Attachment #113712 - Flags: approval1.3b? → approval1.3b-
(Assignee)

Comment 4

16 years ago
Fix to display error msgs checked in. Leave the bug open.
(Assignee)

Comment 5

15 years ago
Marking fixed as bugscape 17509 was fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 6

15 years ago
Verified Fixed.
Status: RESOLVED → VERIFIED
Keywords: nsbeta1
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.