Serif / Sans-Serif choice cannot be made different for different charsets

VERIFIED DUPLICATE of bug 95227

Status

()

VERIFIED DUPLICATE of bug 95227
16 years ago
16 years ago

People

(Reporter: ernestcline, Assigned: smontagu)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

The choice of Serif or Sans-Serif for Proportional fonts is a universal one, but
in some charsets I would prefer to use one or the other. (Actually, I'd prefer
to use Serif for all of them, but the serif fonts I have contain poor Unicode
support, so I really like to use 

Reproducible: Always

Steps to Reproduce:
1. Go to the Fonts pane in Preferences
2. Select a charset (such as Western)
3. Choose Serif for the Proportional font
4. Select a different charset (such as Unicode)
5. Choose Sans-Serif for the Proportional font
6. Go back to the first charset (Western)

The same results occur no matter which two charsets are used
Actual Results:  
The Western charset (and all others as well) now uses Sans-Serif for the
Proportional font for this charset.

Expected Results:  
Allowed Western to remain with Serif while Unicode used Sans Serif.
If this remains a global preference, put the selctor box for Proportional above
the one for the charset and seperate this choice from the choices that can be
made on a per charset basis. The UI certainly creates the impression that this
choice should be doable on a per charset basis, which is the behavior I would
want to have.
(Reporter)

Comment 1

16 years ago
This bug has gotten no attention (not even to confirm that it exists) and is
still present in 1.3 final.  Reaffirming and assigning to another component
where it might get some attention since Preferences does not appear to be the
proper place.
Component: Preferences → Layout: Fonts and Text

Comment 2

16 years ago
.
Assignee: ben → smontagu
Component: Layout: Fonts and Text → Internationalization
QA Contact: sairuh → ylong

Comment 3

16 years ago
This is more like a feature request rather than a bug.

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 95227 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
Verified as dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.