Bug ID wordwraps in change-several-bugs page if window is narrow

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
Query/Bug List
RESOLVED FIXED
16 years ago
6 years ago

People

(Reporter: justdave, Assigned: justdave)

Tracking

2.17.3
Bugzilla 2.18
Bug Flags:
approval +

Details

Attachments

(1 attachment, 1 obsolete attachment)

The checkbox and the Bug ID appear to be in the same table cell in the
change-several screen, which causes the Bug ID to wrap onto a second line if
your window is narrow, which basically makes the screen look funny.  The
checkbox probably ought to be in a separate table cell by itself so the bug ID
doesn't wrap.
Or you could use the <nobr> stuff (or whitespace: <something>; in css)
OK, the nowrap stuff doesn't work all the time if the window is really narrow...
 for some reason the end boundary of an <input> is considered whitespace even if
there isn't any whitespace there.  Dunno if it's a bug in Moz, but it's enough
reason to make it a cell instead.  Had to fix this for Zippy, patch coming up.
Assignee: endico → justdave
Attachment #128221 - Flags: review?(myk)
Comment on attachment 128221 [details] [diff] [review]
Patch

>+      [% IF dotweak %]
>+      <th colspan="[% splitheader ? 3 : 2 %]" align="center">

Looks good, except for the align="center", which doesn't actually align the ID
header to the data in its column.  Have you tried a blank TH tag on top of the
checkbox column instead of adding extra colspan to the ID header?
Created attachment 129275 [details] [diff] [review]
Patch v2

That's a good idea.  done.
Attachment #128221 - Attachment is obsolete: true
Attachment #128221 - Flags: review?(myk)
Attachment #129275 - Flags: review?(myk)
Comment on attachment 129275 [details] [diff] [review]
Patch v2

Looks good, works. r=myk
Attachment #129275 - Flags: review?(myk) → review+
Checking in template/en/default/list/table.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/list/table.html.tmpl,v 
<--  table.html.tmpl
new revision: 1.14; previous revision: 1.13
done
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Flags: approval+
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.18
*** Bug 228346 has been marked as a duplicate of this bug. ***
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.