some error occur when loading to many tabs of specific websites

RESOLVED DUPLICATE of bug 104360

Status

SeaMonkey
Tabbed Browser
RESOLVED DUPLICATE of bug 104360
15 years ago
9 years ago

People

(Reporter: Jörg Heinicke, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: TB17039878Y)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Hi,

I use tabbed browsing heavily, especially when accessing news sites like
www.spiegel.de or www.sueddeutsche.de. But on the last one it sometimes happens
that opening a link in a new tab does not work. I don't know if it has something
to do with the HTML code for the link (<a><span/>&nbsp;<span/></a>), but it's a
possibility. It *is* dependent on the number of already opened tabs. At least I
get following error message in the JavaScript console:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIBrowserBoxObject.docShell]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://global/content/bindings/browser.xml#browser.docShell (getter) :: onget
:: line 0"  data: no]

Now in the tab there is written the URL, which I wanted to load (including tool
tip), but the document is not loaded. If you switch to such a tab, Mozilla will
crash.

Reproducible: Sometimes

Steps to Reproduce:
1. Strg + MouseLeft on a link
2. => around 20, 30 opened tabs
3. maybe one will cause the error message and not load the page

Actual Results:  
nothing if you don't switch to the tab - but if, it will crash

Expected Results:  
load the document and not crash

Comment 1

15 years ago
this is supposed to be fixed in latest nightly build: bug 184363.
Can you try http://ftp.mozilla.org/pub/mozilla/nightly/latest-trunk ?
Keywords: crash, stackwanted
(Reporter)

Comment 2

15 years ago
Another strange behaviour correlating to this bug:

When I choose "Bookmark this group of tabs ..." including such a incorrectly
loaded tab, I get another error message in JavaScript console:

Error: webNav.currentURI has no properties
Source File: chrome://communicator/content/bookmarks/bookmarksOverlay.js
Line: 925

Furthermore an JavaScript alert pops up:

www.bookmarks_groupmark.com could not be found. Please check the name and try again.

Which of course seems to be really strange, but I think you know the internal
processings ...
Summary: crash when switching to a tab, which has not been correctly be opened → crash when switching to a tab, which has not been correctly been loaded

Comment 3

15 years ago
The build is too old for this to be a dup of bug 184363, which first happened
after a checkin on Dec. 3rd.

This is likely dup of bug 156405.
A talkback ID had been fine.. Does talkback trigger? If not: Have you enabled it?
(Reporter)

Comment 4

15 years ago
Yes, of course ;-)

TB17039878Y

(Hey, why it's not possible to copy the TalkbackID from the NS Quality Feedback
Agent's list?)
(Reporter)

Comment 5

15 years ago
At the moment I can reproduce it e.g. with the link "Großbritannien - 
Peinliches Papier" in the first block on www.sueddeutsche.de when opening it
about 15 times.

Updated

15 years ago
Whiteboard: TB17039878Y

Comment 6

15 years ago
I'm using Mozilla 1.3B, recently installed on Win-98.

Browser crashes when I have one tab loading and I continue scroll in the other
tab.  This is frequens but too random to isolate easily. Sometimes it crashes
when I have moved back to the loading tab. I also notice that the "m" logo,
stops morphing on the load when the crash happens.  So it is not an animated GIF
but a real activity on the part of the browser. Could this little component be
the culprit?  May be something worth looking into.

This bug number, 192386, was the closest to the description of my situation. 
Unlike the original report I get this with as few as two tabs.

I am writing this in the third of three open tabs. However, I am not currently
scrolling any of the others. and no tabs are loading at the moment.

Comment 7

15 years ago
does this still happen with latest 1.3 build ?
http://ftp.mozilla.org/pub/mozilla/nightly/latest-1.3
(Reporter)

Comment 8

15 years ago
Using the latest build (20030312) the error still occurs, but the broser doesn't
crash anymore when switching to those tabs. Now in the JavaScript console I have
the following error:

Error: this.docShell has no properties
Source File: chrome://global/content/bindings/browser.xml#browser.webProgress
(getter)
Line: 0

Those tabs are still not closeable or usable in any form. The window must be
completely closed.

The bug seems to be always reproducable using the website
http://www.sueddeutsche.de. Simply take any headine and open it about 20 times
in a new tab.
(Reporter)

Comment 9

15 years ago
Changed severity to normal, because the browser does not crash any more with
Mozilla 1.3.

Furthermore it's possible to at least "reactivate" the tab: open a new tab in
this window, close this new tab => the bad tab is reset to a normal about:blank
tab. But it's still not closable and it behaves not correctly, e.g. the
"pondering circle" is missing when loading a page.

What about the bug status?
Severity: critical → normal
Summary: crash when switching to a tab, which has not been correctly been loaded → some error occur when loading to many tabs of specific websites
(Reporter)

Comment 10

15 years ago
What's up with this bug? At least the test page http://www.sueddeutsche.de has
changed its layout/design (no longer use of heavy iframes) and can no longer be
used as test case.

Comment 11

15 years ago
do you still crash using 1.4 ?
(Reporter)

Comment 12

15 years ago
No, already Mozilla 1.3 did not crash anymore. Only "bad" tabs were created that
could not be closed. But I no longer have a test case.

Joerg

Comment 13

15 years ago
Marking WFM as per reporter comments.

the tabs that could not be closed is tracked in bug 112337.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 14

15 years ago
Ok, thanks. CCed there.
(Reporter)

Comment 15

15 years ago
.
Status: RESOLVED → CLOSED

Comment 16

15 years ago
reopening, bug reports shouldn't be "closed".
Status: CLOSED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 17

15 years ago
re-resolving WFM, sorry for the spam.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 18

15 years ago
I'm not sure if the pointed bug meets me bug description. It seems to be only
about loosing focus and so keyboard events. So I want to reopen this bug.

My bug is worse: You open a new tab (by Ctrl+T or "open link in new tab"), but
an invalid tab is created. The tabpanel is not switched to this new tab (due to
JavaScript error). You can switch to this tab by hand, but you can't close this
tab (due to JS error).

The original bug was about a crash when switching to such an invalid tab. This
no longer happens, but invalid tabs are still created. The problem is not
regularly reproducable, but it happens sometimes.

Please read also my comments #2, #8 and #9.

Joerg

Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 19

14 years ago

*** This bug has been marked as a duplicate of 104360 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago14 years ago
Keywords: crash, stackwanted
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.