HTML command "ruby" unsupported

RESOLVED DUPLICATE of bug 33339

Status

()

Core
Layout
--
enhancement
RESOLVED DUPLICATE of bug 33339
16 years ago
16 years ago

People

(Reporter: Stefan Persson, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

The HTML standard includes a command for "furigana" -- that is, pronunciation
hints above ideographic characters in East-Asian languages.  The syntax for this
command is described at http://www.w3.org/TR/ruby/.  It is also suggested for
inclusion in CSS3, though it has not yet been fully approved, see
http://www.w3.org/TR/css3-ruby/.  These two web pages also mention vertical
writing and how the ruby field should be displayed in such cases.  As far as I
know, vertical writing is not yet supported in HTML, XHTML or CSS, but I think I
saw some proposal for that to CSS3 not a very long time ago, so you might have
to deal with that matter later.

What happens when I use the ruby tag is that Mozilla simply ignores the <ruby>,
<rb> and <rt> syntaxes.

Reproducible: Always

Steps to Reproduce:
1. No special setup needed.
2. Create a HTML file, anything.html, that contains the text
"<ruby><rb>text</rb><rt>TEXT</rt></ruby>".
3. Open that file in Mozilla.
Actual Results:  
Correct display means that the word "TEXT" is written with a smaller font above
the word "text"; however, Mozilla does instead display it as "textTEXT".

Expected Results:  
Correct display means that the word "TEXT" is written with a smaller font above
the word "text"; however, Mozilla does instead display it as "textTEXT".

I used this tag with JavaScript disabeled, but platforms and settings are
probably unimportant in this case.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 33339 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.