Authenticated smtp server not available for selection into an account

VERIFIED DUPLICATE of bug 86370

Status

SeaMonkey
MailNews: Account Configuration
VERIFIED DUPLICATE of bug 86370
15 years ago
13 years ago

People

(Reporter: Matteo, Assigned: racham)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

I've two smtp servers, the default working without authentication, and another
one which requires username and password.
The problem is that in all the accounts if I select the 'advanded' button for
choosing which smtp server the account must use, only the default server is
available for selection; if I remove the authentication request in the
configuration of the smtp server, it becomes available for selection.
The entries in prefs.js are these:
user_pref("mail.smtp.defaultserver", "smtp1");
user_pref("mail.smtpserver.smtp1.auth_method", 0);
user_pref("mail.smtpserver.smtp1.hostname", "mail.mydomain.dot");
user_pref("mail.smtpserver.smtp1.try_ssl", 0);
user_pref("mail.smtpserver.smtp1.username", "");
user_pref("mail.smtpserver.smtp2.auth_method", 1);
user_pref("mail.smtpserver.smtp2.hostname", "mail.authdomain.dot");
user_pref("mail.smtpserver.smtp2.try_ssl", 1);
user_pref("mail.smtpserver.smtp2.username", "username@authdomain.dot");
user_pref("mail.smtpservers", "smtp1,smtp2");

And identities of account setup with default server are like this one:
user_pref("mail.identity.id7.smtpServer", "");


Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
To ensure that you are selecting the appropriate dialogs to associate an account
with the correct SMTP server please review the following:

- In the Outgoing SMTP Server panel, select the Advanced button to add the
server which requires authentication (username and password). It should then
list the default smtp server and the authenticated server.
- Next make sure that the account is associated with the appropriate SMTP
server.In the Account Settings window select the account (top level panel) so it
states "Account Settings - <account name>" in the top right panel. Select the
Advanced button, click on the down arrow to see a list of servers. You should
see two servers. If you have the authenticated account selected then choose the
authenticated SMTP server.
(Reporter)

Comment 2

15 years ago
> In the Account Settings window select the account (top level panel) so it
> states "Account Settings - <account name>" in the top right panel. Select the
> Advanced button, click on the down arrow to see a list of servers. You should
> see two servers.

I see the two servers if the username for the authenticated server is simply
'username'; I see only the unauthenticated server if the username for the
authenticated one is like 'username@server'.
(Reporter)

Comment 3

15 years ago
Same problem with 1.3b: if the username is completed with the domain
(user@domain.dot), it's not available for selection from account settings; if
the username is just "user", it's available for selection.

Comment 4

15 years ago
Seems to be a duplicate of http://bugzilla.mozilla.org/show_bug.cgi?id=86370 ...
(Reporter)

Comment 5

15 years ago
Yes, it is.

*** This bug has been marked as a duplicate of 86370 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 6

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.