Address completion causes sending messed up To: header

RESOLVED DUPLICATE of bug 103917

Status

RESOLVED DUPLICATE of bug 103917
16 years ago
14 years ago

People

(Reporter: andrewm, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

Address completion looks in you address book and gives you an address like
  andrewm >> "Andrew E. Mileski" <andrewm@netwinder.org>
Pressing Send at this point cause this ENTIRE string to be used.

Reproducible: Always

Steps to Reproduce:
1. Open a compose window.
2. Click on subject, and enter a subject
3. Click on the message body, and enter some text.
4. Click on the To: field and start typing an address that is in your address book.
5. When the >> appears in the address, click Send.

Actual Results:  
To: andrewm >> "Andrew E. Mileski" <andrewm@netwinder.org>

Expected Results:  
To: "Andrew E. Mileski" <andrewm@netwinder.org>

Clicking send should acknowledge the address book entry shown is indeed the one
desired, and complete the line according to the address book entry.

Comment 1

16 years ago
Confirming; replicated with 1.3 final and
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 103917 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.