Status

SeaMonkey
Preferences
--
enhancement
VERIFIED DUPLICATE of bug 38966
15 years ago
13 years ago

People

(Reporter: Jaroslav Zaruba, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: 

Hi

I think it would be nice to have more complex site-policies in Mozilla. Each
rule would look like this:

---
on domain(s):
  [ *.geocities.com; *.microsoft.com           ]
  (use semicolons to separate entries)

[ ] disable javaScript
  [x] disable window resizing
   ...
   ...
  [x] disable opening unrequested windows

[ ] disable cookies
  ( ) disable third-sites cookies
  (o) prompt

use following userAgent:
  [ myBrowser from myCompany version 0.95      ]

...
anything else ?
...
---

I personally don't like userAgent-changing, but this way it would solve the
problem Opera users are faced these days. (MSN sends wierd CSS to the Opera
browsers.) WHo knows when they will aim the Mozilla ?

  Yaroukh

Reproducible: Always

Steps to Reproduce:




I have just read somewhere on the Bugzilla that identifying the host-name with
the mask ("*.geocities.com") would lead to a performance loss. But I don't agree
- such an identification would be done one-time per a request.
(Reporter)

Updated

15 years ago
OS: Linux → All
This is already covered by other bugs.
Whiteboard: DUPEME

Comment 2

15 years ago
It's basically a dup of 38966.

*** This bug has been marked as a duplicate of 38966 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
v dup.
Status: RESOLVED → VERIFIED
Whiteboard: DUPEME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.