Picture which spans a pagebreak prints incorrectly, small distorted version of complete picture appears on each page

RESOLVED DUPLICATE of bug 234095

Status

()

RESOLVED DUPLICATE of bug 234095
16 years ago
15 years ago

People

(Reporter: markwatkins, Assigned: rods)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210

When printing the page at
http://users.ox.ac.uk/~chess/articles/bishop_knight_mate.html to A4 two of the
pictures span page-breaks.  It looks fine in print preview, but when printing
the page-span pictures come out twice, i.e. once at the bottom of page 1, and
once at the top of page 2, and compressed vertically into the space they would
have taken up normally.  The pictures are GIFs.

Damn, I hope that makes sense - perhaps someone else can look at this and
describe it better ;)

btw: IE6 and Opera7 avoid this sort of schenanigan by bumping the entire picture
on to the next page, which is desirable in the example given here, but possibly
not when printing in general.

Reproducible: Always

Steps to Reproduce:
1. Go to http://users.ox.ac.uk/~chess/articles/bishop_knight_mate.html
2. I'm printing to A4, not letter size paper
3. Print the page (printing via Print Preview first doesn't alter the outcome)

Actual Results:  
The picture which spans pages 1 and 2 appears in full compressed vertically at
the bottom of page 1, and compressed vertically at the top of page 2.

Expected Results:  
The picture should appear only once and with a normal aspect-ratio.  Whether it
does this divided down the middle between pages, or with the top of the picture
bumped onto the next page doesn't matter to me.

Comment 2

16 years ago
CONFIRMing using Moz1.3b on WinXP
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 146799 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
v
Status: RESOLVED → VERIFIED

Comment 5

15 years ago
Not really a duplicate of bug 146799. 146799 is just about splitting images
across two pages; it has morphed to include the image-squashing aspect but this
wasn't mentioned by the original reporter. Image-squashing doesn't occur on
linux (the bug 146799 reporter's platform) so it may be windows-specific. I
intend to WONTFIX 146799 and I don't want to lose the image-squashing issue.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 6

15 years ago
Resolving as a dupe of bug 234095 based on the platform and the image-squashing
aspect.

*** This bug has been marked as a duplicate of 234095 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.