[rel pos] with style property "height" DIV renders different in mozilla 1.3a and 1.3b

RESOLVED DUPLICATE of bug 191830

Status

()

Core
Layout: View Rendering
RESOLVED DUPLICATE of bug 191830
15 years ago
15 years ago

People

(Reporter: Saulius Gurklys, Assigned: roc)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

In the page http://www.vtex.lt/sagu/mozilla/dh.html, middle <TABLE> in <DIV>
renders different in Mozilla 1.3a and Mozilla 1.3b. 

This happens because of DIV's (id "this_div") attribute "style" property "height".

So I do not know is this a NEW bug in 1.3b, or there was a bug in 1.3a.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
Middle table (with "c c c c") overlaps the pink row.

Expected Results:  
I think middle table should not ovelap pink row.

Comment 1

15 years ago
It look like something changed in the wayn a relatively positioned element's
height (and width?) is being calculated. The original position of the box is
sticking to the declaration of height regardless of the actual rendederd size of
the element. Previously the "hole" left in the layout was always the same size
as the element as it ultimately displayed.

Try zooming your text & you'll see what I'm talking about. I don't immediatly
know why this is happening. But it *could* break a lot of relative posisioned stuff
Summary: with style property "height" DIV renders different in mozilla 1.3a and 1.3b → [rel pos] with style property "height" DIV renders different in mozilla 1.3a and 1.3b
The new rendering is almost correct.  1.3a was buggy (bug 180711).  Note that
the rendered size of the <div> does _not_ include the overflowing part of the table.

The fact that the table overlaps the following div instead of the other way
around is the only problem I see in that testcase, and that's bug 191830

*** This bug has been marked as a duplicate of 191830 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.