Documents (e.g. *.pdf) not opened by according plugins, only save-to-disk available

RESOLVED DUPLICATE of bug 185618

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 185618
16 years ago
14 years ago

People

(Reporter: Matthias Röper, Assigned: asa)

Tracking

Trunk
Other
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.2.1) Gecko/20021130

Although plugins for pdf-files are installed (plugger & acrobat plugin), they ar
not used for opening a document. The mime-type is correctly recognized
(application/pdf). It only seems to happen in Mozilla 1.2.1 (en and de
-version), whereas Mozilla 1.0 works o.k. Using the paket sniffer etheral under
linux, i found out that this only happens if the Web-Server delivers the
document with the "content-disposition" field. This is true e.g. for the
BSCW-Document Managing System (http://www.bscw.de) using Apache as Web-Server.

Reproducible: Always

Steps to Reproduce:
1.demand a .pdf document from the BSCW-application
2.
3.

Actual Results:  
save-to-disk window opens (to decide whether open using application / save to disk)

Expected Results:  
open the plugin associated with the mime-type (acrobat reader plugin) in the browser
Is this true for any value of "Content-Disposition:", or only for 
"Content-Disposition: attachment"? If the latter, it's a duplicate of bug 
185618, I think.

Comment 2

15 years ago
pdf files fail to load *every time* with Mozilla 1.3 under Linux; why is this
bug still unconfirmed? And given the number of pdf documents on the web, why is
severity "normal"?

All pdf loads failed on the mozilla test page at
http://www.mozilla.org/quality/browser/front-end/testcases/plugins/acrobattest.html,
except for the broken links (test 1 and test 6). "Open with program" is useless
when we have no idea where mozilla buried the plug-in, or even what it's called.
it is by design that the helper app dialog appears for disposition:attachment.
marking duplicate of bug to allow showing the file in the browser in such cases.

*** This bug has been marked as a duplicate of 185618 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
No longer depends on: 185618
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.