Mozilla does not wrap the text inside a table if there are no "white-space" present

RESOLVED DUPLICATE of bug 95067

Status

()

defect
RESOLVED DUPLICATE of bug 95067
17 years ago
17 years ago

People

(Reporter: clan_admin, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

17 years ago
User-Agent:       007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

Both Netsccape 7.01 and Mozilla 1.2.1 demonstrated the same problem although Netscape 6.02 did not have the same problem.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2) Gecko/20021120 Netscape/7.01
Also
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

Problem occurs if a long string of text without any white-spaces is placed inside a tables (may also be relevant outside the table but I have not tried it). IE and Opera force wrap the text to fit inside the table width but New Netscape and Mozilla does not and the result is an extended table which can go well beyond the page.
As a webdesginer, my priority is to make the page look the same while viewed with different browsers.
Another example can be seen here
http://www.cybersyndrome.net/evc.html
The string in question is the same, since they are not many instances of long strings without white-space except in http headers.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.




I have tried with CSS, manually inputing width for the table and the columns but was not able to get Mozilla to wrap the text.
Reporter

Comment 1

17 years ago
The effect should be seen at the line displaying
HTTP_ACCEPT

text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,text/css,*/*;q=0.1 

Comment 2

17 years ago
Not sure if this is a problem or not. From looking at the source, the Table is
defined with a width of "100%" (and thus it is a problem). However, further down
is a TD with a width of "150".

If I remember correctly, mixing percentages and pixel values is not a good idea.
What happens if you remove the width="150" ?

Comment 3

17 years ago
despite any errors in the sample, bugzilla has problems with long strings in tables.

*** This bug has been marked as a duplicate of 95067 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.