Words wrap in nowrap cell when width=0 and next cell have width=100%

RESOLVED FIXED in Future

Status

()

Core
Layout: Tables
P3
normal
RESOLVED FIXED
15 years ago
8 years ago

People

(Reporter: joakim_46, Assigned: Bernd)

Tracking

({testcase})

Trunk
Future
testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: 2003021008

As you can see, the Sony Ericsson T200 (top) is outlined.

Reproducible: Always

Steps to Reproduce:
1. Start Mozilla
2. Load http://www.telemoveis.com/catalog/itemcomments.asp?id=841
3.

Actual Results:  
The page opens correctly, but the Sony Ericsson T200 shouldn't be outlined.

Expected Results:  
The Sony Ericsson T200 text should be displayed correctly.

Comment 1

15 years ago
From the code:
<td background="/images/sub_folder_mid.gif" width="0" nowrap="nowrap"
class="titulosproduto">Sony Ericsson T200</td>

The td has a width="0", though it also has nowrap.
tables; sounds like nowrap broke....
Assignee: asa → table
Component: Browser-General → Layout: Tables
QA Contact: asa → madhur

Comment 3

15 years ago
Though the problem seems to be something else, cause this works fine:
<table>
<tr>
	<td width="0" nowrap="nowrap">Does this wrap?</td>
</tr>
</table>

Updated

15 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 4

15 years ago
-> All/All (OS X 1.4a)
OS: Windows XP → All
Hardware: PC → All

Comment 5

15 years ago
Created attachment 128032 [details]
Testcase

Updated

15 years ago
Keywords: testcase
Summary: Text outlined → Words wrap in nowrap cell when width=0 and next cell have width=100%
(Assignee)

Comment 6

15 years ago
the pixel width on the td wins over  the nowrap attribute
(http://lxr.mozilla.org/seamonkey/source/content/html/content/src/nsHTMLTableCellElement.cpp#506)
this might be not correct :-)
(Assignee)

Comment 7

9 years ago
The question here is if we need this quirk. IE and webkit do not have it, Opera does what we do.
(Assignee)

Comment 8

9 years ago
Created attachment 373561 [details] [diff] [review]
patch

glacial speed, but here we go
Assignee: layout.tables → bernd_mozilla
Status: NEW → ASSIGNED
Attachment #373561 - Flags: superreview?(bzbarsky)
Attachment #373561 - Flags: review?(bzbarsky)
Comment on attachment 373561 [details] [diff] [review]
patch

Even more glacial review... r+sr=bzbarsky
Attachment #373561 - Flags: superreview?(bzbarsky)
Attachment #373561 - Flags: superreview+
Attachment #373561 - Flags: review?(bzbarsky)
Attachment #373561 - Flags: review+
Pushed http://hg.mozilla.org/mozilla-central/rev/2f6f827fd7f6
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Depends on: 527464
You need to log in before you can comment on or make changes to this bug.