non-ascii file name will display garbled in save as dialog when encoding of document is different than OS

RESOLVED WORKSFORME

Status

()

Core
Internationalization
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Yuying Long, Assigned: Jungshik Shin)

Tracking

({intl})

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Build: 02-11 trunk build on Windows and linux

Steps to reproduce:
1. Load a page that has different encoding that OS, e.g. http://www.asahi.com
(euc-jp) in windows JA system (shift-jis), or http://www.yomiuri.co.jp
(shift-jis) on linux JA system (euc-jp).
2. File | Save Page As, name the file as Japanese and save.
3. Close the browser window and open the file again.
- the Japanese file name is displayed fine in system file list.
4. File | Save Page As again.

Result:
The Japanese file name characters are garbled inside the dialog.

It seems the document encoding overwrite the system encoding inside the dialog.
(Reporter)

Comment 1

16 years ago
01-12 MachO build doesn't has the problem.
Assignee: smontagu → ftang

Comment 2

16 years ago
for window, this is because we does not finish the winxp/win2k unicode file
system work. 
Status: NEW → ASSIGNED

Comment 3

14 years ago
what a hack. I have not touch mozilla code for 2 years. I didn't read these bugs
for 2 years. And they are still there. Just close them as won't fix to clean up.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

14 years ago
Status: RESOLVED → REOPENED
Depends on: 162361
Resolution: WONTFIX → ---
(Assignee)

Updated

14 years ago
Assignee: ftang → jshin1987
Status: REOPENED → NEW
I can't reproduce this in current trunk.
Status: NEW → RESOLVED
Last Resolved: 14 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.