If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

POST requests are resubmitted on Save Page, without warning.

RESOLVED DUPLICATE of bug 115174

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 115174
15 years ago
4 years ago

People

(Reporter: Luke Ross, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211

Attempting to save pages that are the result of POST requests can sometimes
result in the form being resubmitted, without warning.  This occurs with the
disk cache turned on.  In an e-commerce site, this could result in, say,
reordering or similar problems.

This problem occurs in 1.3b but not 1.2.1 on Linux.

Reproducible: Always

Steps to Reproduce:
1.  Go to URL
2.  Press "Do post"
3.  Go to File->Save As and save page
4.  Compare timestamps between browser window and saved version.

Actual Results:  
The timestamps differ, suggesting the page was resubmitted to the server.  No
warning is issued.

Expected Results:  
Either:
1. Save the page from the cache
2. Warn that the form must be reposted, with OK/Cancal options.

Apologies for not finding this the correct category, but I didn't know if it was
a file: problem or a DOM problem.

This issue is a major problem - e-commerce sites often recommend you save the
page confirming order number etc, but this bug could cause multiple orders to be
placed without the user being aware.

Comment 1

15 years ago
I see it too.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030209
I did notice that if you save as page as complete it will not re POST the page.
Whiteboard: DUPEME

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 115174 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.