option with "selected" attribute is not restored on reload

VERIFIED DUPLICATE of bug 46845

Status

()

Toolkit
Form Manager
VERIFIED DUPLICATE of bug 46845
15 years ago
9 years ago

People

(Reporter: thierry schmit, Assigned: dveditz)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

if you load the following html then option 1 is selected
but if you chose option 0 (or 2) and do a reload, option 1
is not re-selected !!!

<html>
<head />
<body>
<form name="form1">
  <select name="select1">
     <option value ="0">0</option>
     <option selected value ="1">1</option>
     <option value ="2">2</option>
  </select>
</form>
</body>
</html>

Reproducible: Always

Steps to Reproduce:
see details
Actual Results:  
see details

Expected Results:  
in my mind option 1 must be selected on both load and reload

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: tpreston → form.manager
You need to log in before you can comment on or make changes to this bug.