Adding any control to blacklist closes mozilla when any active-x content opened

VERIFIED FIXED in mozilla1.3final

Status

Core Graveyard
Embedding: ActiveX Wrapper
VERIFIED FIXED
15 years ago
6 years ago

People

(Reporter: Ashish Bhatt, Assigned: Adam Lock)

Tracking

Trunk
mozilla1.3final
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.69 KB, patch
David Bradley
: review+
Alec Flett
: superreview+
dbaron
: approval1.3+
Details | Diff | Splinter Review
(Reporter)

Description

15 years ago
Tested with 2003-02-13

Steps to reproduce
1. Add any control to HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\ActiveX\Blacklist\CLSID
2. Start mozilla
3. Open page with Active-x content
(Assignee)

Comment 1

15 years ago
Created attachment 114432 [details] [diff] [review]
Patch

Small patch

Bustage caused by a loop that didn't break properly, meaning a counter would
spin forever trying to enumerate keys. I also noticed two args in the plugin
were mixed up causing controls on the whitelist to be ignored.
(Assignee)

Comment 2

15 years ago
Comment on attachment 114432 [details] [diff] [review]
Patch

Dave & Alec, can you r/sr this simple patch please? It fixes the
blacklist/whitelist lookup in the COM connect object & plugin. Thanks
Attachment #114432 - Flags: superreview?(alecf)
Attachment #114432 - Flags: review?(dbradley)

Comment 3

15 years ago
Comment on attachment 114432 [details] [diff] [review]
Patch

sr=alecf
Attachment #114432 - Flags: superreview?(alecf) → superreview+

Comment 4

15 years ago
Comment on attachment 114432 [details] [diff] [review]
Patch

r=dbradley
Attachment #114432 - Flags: review?(dbradley) → review+
(Assignee)

Comment 5

15 years ago
Comment on attachment 114432 [details] [diff] [review]
Patch

Seeking 1.3 approval ActiveX / COM connect specific. Low risk obvious fixes.
Attachment #114432 - Flags: approval1.3?
Attachment #114432 - Flags: approval1.3? → approval1.3+
(Assignee)

Comment 6

15 years ago
Fix is checked in
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

15 years ago
verified on 2003-17-02 build
Status: RESOLVED → VERIFIED

Updated

15 years ago
Target Milestone: --- → mozilla1.3final
Component: Embedding: ActiveX Wrapper → Embedding: ActiveX Wrapper
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.