Recursive iframe: bug or feature?

RESOLVED INVALID

Status

()

RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: biro.arpad, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

Mozilla renders recursive iframes, well, recursively.

Reproducible: Always

Steps to Reproduce:
Load the following code with Mozilla:

<html><head><title>Test</title></head>
<body>Test
<iframe width="100%" height="300" src="#"></iframe>
</body>
</html>

Actual Results:  
Mozilla renders it recursively.
(Reporter)

Comment 1

16 years ago
Created attachment 114430 [details]
Recursive iframe sample

Comment 2

16 years ago
If anyone is interested, IE just renders an empty page (just an <html></html>
pair) in the inside box.
jkeiser, didn't we have code to prevent this?
I thought we had some sort of frame nesting depth to prevent this...we 
should make sure it's hooked up to <object>, too.

Comment 5

16 years ago
I can only get it to recurse itself about 32 times.  The innermost frame is
completely black.  Win2k, SP3, 1.3b.

Comment 6

16 years ago
-> All/All based on 1.3b/OS X

(I also vaguely remember this having no effect when I tried to break the browser
a long long long time ago. perhaps it was just frames tho)

OS: Windows 2000 → All
Hardware: PC → All
Attachment #114430 - Attachment mime type: text/plain → text/html

Comment 7

16 years ago
If you ask for the iframe to be pointed at a "#" URL relative to the current
document, we happily do what you say.  Doing what the programmer says is a
feature. :)

If recursion protection is not enabled, that's another thing altogether.  But it
looks like it is.  And <object> recursion protection probably works right now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.