Text without blanks in TEXTAREA not wrapping

RESOLVED DUPLICATE of bug 95067

Status

()

defect
RESOLVED DUPLICATE of bug 95067
17 years ago
17 years ago

People

(Reporter: rrkurtz, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

17 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

Text in a TEXTAREA is not being wrapped if the text does not contain any spaces.
Works with Internet Explorer 6.x and Netscape 4.61 (under OS/2).

Since my http server is inside a corporate firewall, I'm including sample html
that illustrates the problem. It includes textareas for wrap off, physical and
virtual, with and without a space.

<html><body><form>
 <p>wrap=off no space</p>
  <textarea name=a rows=2 cols=20 wrap=off
  
value=aaaaaaaaa,aaaaaaaaa,aaaaaaaaa,aaaaaaaaa>aaaaaaaaa,aaaaaaaaa,aaaaaaaaa,aaaaaaaaa
  </textarea><br>
 <p>wrap=off +space</p>
  <textarea name=a rows=2 cols=20 wrap=off
   value=aaaaaaaaa,aaaaaaaaa,aaaaaaaaa,aaaaaaaaa>aaaaaaaaa,aaaaaaaaa,
aaaaaaaaa,aaaaaaaaa
  </textarea><br>
 <p>wrap=physical no space</p>
  <textarea name=b rows=2 cols=20 wrap=physical
  
value=aaaaaaaaa,aaaaaaaaa,aaaaaaaaa,aaaaaaaaa>aaaaaaaaa,aaaaaaaaa,aaaaaaaaa,aaaaaaaaa
  </textarea>
 <p>wrap=physical +space</p>
  <textarea name=b rows=2 cols=20 wrap=physical
   value=aaaaaaaaa,aaaaaaaaa,aaaaaaaaa ,aaaaaaaaa>aaaaaaaaa,aaaaaaaaa,
aaaaaaaaa,aaaaaaaaa
  </textarea><br>
 <p>wrap=virtual</p>
  <textarea name=c rows=2 cols=20 wrap=virtual
  
value=aaaaaaaaa,aaaaaaaaa,aaaaaaaaa,aaaaaaaaa>aaaaaaaaa,aaaaaaaaa,aaaaaaaaa,aaaaaaaaa
  </textarea>
 <p>wrap=virtual +space</p>
  <textarea name=c rows=2 cols=20 wrap=virtual
   value=aaaaaaaaa,aaaaaaaaa,aaaaaaaaa,aaaaaaaaa>aaaaaaaaa,aaaaaaaaa,
aaaaaaaaa,aaaaaaaaa
  </textarea>
</form></body></html>


Reproducible: Always

Steps to Reproduce:
No setup require. Just cut and paste the html in Details above and point Mozilla
at it to see the problem. 

Actual Results:  
Text in the TEXTAREA did not wrap.

Expected Results:  
Wrapped the text as specified.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 95067 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.