Wrong display of input file if style="width: " is set

RESOLVED DUPLICATE of bug 52500

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 52500
15 years ago
4 years ago

People

(Reporter: Johann - Nikolaus Andreae, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.1; Linux)
Build Identifier: http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.3b/mozilla-win32-1.3b-installer.exe

the style="width:" atribut from the <input type=file> element make a wite shadow. if the 
element is includen in a tabele the chouse button resize (hight) on a click in the 1.2.1 version 
the houle table make a jump to the right side. 

Reproducible: Always

Steps to Reproduce:
1. open this code in mozilla 
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" 
        "http://www.w3.org/TR/html4/loose.dtd"> 
<html> 
 
<head> 
<title>Bug exampel</title> 
<meta http-equiv="content-type" content="text/html; charset=iso-8859-1"> 
</head> 
<body bgColor="#0099FF"> 
 
<form enctype="multipart/form-data" action="" method="POST"> 
   <input style="width: 500pt;" type="file" name="link"> 
</form> 
 
<form enctype="multipart/form-data" action="" method="POST"> 
   <table> 
      <tr> 
         <td><input style="width: 500pt;" type="file" name="link"></td> 
      </tr> 
   </table> 
</form> 
 
</body> 
</html> 
Actual Results:  
set the width of the shadow 

Expected Results:  
set the width of the element
This is a dup.
Assignee: jst → form
Component: DOM Style → Layout: Form Controls
QA Contact: ian → desale
Whiteboard: DUPEME

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 52500 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.