Last Comment Bug 193924 - Support <xml-stylesheet href="#local" type="text/css" ?>
: Support <xml-stylesheet href="#local" type="text/css" ?>
Status: RESOLVED DUPLICATE of bug 61675
: helpwanted, testcase
Product: Core
Classification: Components
Component: XML (show other bugs)
: Trunk
: x86 Windows 98
: -- normal (vote)
: Future
Assigned To: Heikki Toivonen (remove -bugzilla when emailing directly)
: Ashish Bhatt
Mentors:
http://www.w3.org/Style/styling-XML#E...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-18 13:51 PST by Alex Vincent [:WeirdAl]
Modified: 2003-02-18 14:48 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Alex Vincent [:WeirdAl] 2003-02-18 13:51:17 PST
The W3C suggests in the URL-referenced document that embedded stylesheets can be
referenced by an XML ID-type attribute.  Although technically the above is not
part of any W3C Recommendation, the document implies it should be considered as
part of or an amendment to CSS2 (at the top of the page).

http://www.w3.org/Style/Examples/002/doc.xml is a testcase they were kind enough
to provide.

Currently, Mozilla gives us an exception for that behavior:
Error: The stylesheet http://www.w3.org/Style/Examples/002/doc.xml#style was not
loaded because its MIME type, "text/xml", is not "text/css".

This bug may be a duplicate, but heikki and I could not find another bug filed
for this issue.
Comment 1 Boris Zbarsky [:bz] (Out June 25-July 6) 2003-02-18 14:04:05 PST
All I have to say is "eh".  ;)  We _could_ add support for this via the XML
sink; it'd have to notice such PIs and stash them away or something and then
when the element with the matching ID comes along it could kick off the sheet
load....

More interestingly, the example being cited is totally broken because the sheet
is not inside a CDATA section and will thus get parsed into real text nodes (and
worse yet, '<' and '>' chars in it will be parsed).

I have a gut feeling that as currently presented that example is a really bad
idea.....
Comment 2 Hixie (not reading bugmail) 2003-02-18 14:48:07 PST
Heikki commented on the dupe. :-)

*** This bug has been marked as a duplicate of 61675 ***

Note You need to log in before you can comment on or make changes to this bug.