select population behave differently if you click on an element or if you move through the elements with arrows

VERIFIED DUPLICATE of bug 126379

Status

()

Core
DOM: Core & HTML
--
minor
VERIFIED DUPLICATE of bug 126379
15 years ago
15 years ago

People

(Reporter: Federico Fissore, Assigned: jst)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210

OnChange event on select object behaves differently when using mouse click or
arrow keys

first select lists all departures available. selecting one makes the arrivals
select re-populate. if you select an element by mouse click from the first
select, second select re-populate correctly, but if you move through the first
select elements by arrow keyboard, second select re-populate only after first
select has lost focus

Reproducible: Always

Steps to Reproduce:
1. choose a departure by mouse click. you see the arrivals list repopulate
2. choose a departure by using the arrow keys.
3. if you do not switch on another element, second select DOES NOT repopulate

Actual Results:  
arrivals select does not repopulate correctly

Expected Results:  
onchange event should be fired even when changing is done by using arrorw keys

Comment 1

15 years ago
This is the expected behaviour

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.