Tabbed Browsing seems completely broken

VERIFIED DUPLICATE of bug 194099

Status

()

Firefox
General
--
major
VERIFIED DUPLICATE of bug 194099
16 years ago
13 years ago

People

(Reporter: Akshay Arora, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030219 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030219 Phoenix/0.5

Sometimes middle-clicking on a link will open the tab and load the page,
othertimes it will load up a blank page which will not close. You can close the
page from where the link came from, but when you open up a new tab (Ctrl-T) you
will see that the window didn't really close, just disappeared and remained
alive. Middle-Clicking to close Tabs doesn't quite work properly either.

Reproducible: Always

Steps to Reproduce:
1. Go to any web-site.
2. Middle-click on links until you get a site that does not load up. Should be
first page you try, if not then soon after.
3. Close the tab which has nothing loaded. You can't.
4. Close the original Tab.

Note: Sometimes you can close the "new blank" tab, but when you open another tab
after you will see that the "new blank" tab didn't actually close either.
5. Open a blank tab, and you will see the original tab still there.




Using Phoenix nightly build from 02/19/2003 - prior to the Customize Toolbar
Bustage bug fix, since that patch was applied too late to make it into the
nightly binary.

Comment 1

16 years ago
wfm
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

Comment 2

16 years ago
This bug seems to have first appeared in the 02/19 build of Phoenix.  Reporter,
can you please verify that this happens in Mozilla, too.  Otherwise this should
be switched over to Phoenix. 

Comment 3

16 years ago
reporter: Are you mixing profiles between different gecko related browsers?
That can cause profile corruption like corrupted cache, broken bookmarks and more.

The "unclosable blank tab" is dup of bug 112337.
But the cause of the many blank tabs you describe here is unclear.. haven't seen
that in Mozilla. Are you using a proxy?
(Reporter)

Comment 4

16 years ago
I could not find the appropriate section in Phoenix to put this under, so I
thought it would go better here. I will gladly switch it over to Phoenix, but I
don't think there is as clearly defined a section.

I did not mix profiles - deleted completely.

Also, sometimes the blank tabs will close - rather, disappear (if there is only
one other tab left to close) and then re-appear when you open another tab. Then
you can't make them disappear anymore because there are more than 2 tabs. I
don't know if I really described that well or not.

Any suggestions as to where in Phoenix I should file this?

Comment 5

16 years ago
tab browsing is totally screwed in phoenix.  a few observations.  
1. this is phoenix only. please move it to phoenix
2. many tabs refuse to close, these tabs can have content or blank pages.  they
will not close via context menu or via the close button.
3. sometimes the tab bar will disappear for no reason, even if there are many
tabs open.  later it will reappear.
4. in some tabs the url bar will not update itself after clickin on links,
submitting forms
5. open in new tab does not work all the time
6. ctrl+T does create a new tab
7. there is also a lot of other screwiness such as pages disappearing completely
after a tab is closed.
8. occurs even after i create a new profile
i'm using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b)
Gecko/20030220 Phoenix/0.5
(Reporter)

Comment 6

16 years ago
Changing to Phoenix.
Component: Tabbed Browser → General
Product: Browser → Phoenix
Version: Trunk → unspecified

Comment 7

16 years ago
Second dupe today.

*** This bug has been marked as a duplicate of 194099 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

15 years ago
v
Status: RESOLVED → VERIFIED

Updated

15 years ago
QA Contact: pmac → bugzilla

Updated

13 years ago
QA Contact: bugzilla → general
You need to log in before you can comment on or make changes to this bug.